soundcloud delayed playback when skipping fast through long DJ-Mixes

RESOLVED WORKSFORME
(NeedInfo from)

Status

()

Core
Audio/Video: Playback
P3
normal
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: jan, Unassigned, NeedInfo)

Tracking

46 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(platform-rel -)

Details

(Whiteboard: [platform-rel-Soundcloud])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160227004020

Steps to reproduce:

1. Play a soundcloud DJ mix with a minimum length of 1 hour.
For example try this mix i could reproduce this problem:
https://soundcloud.com/johnb/john-b-podcast-161-live-pirate-station-circus-russia-2016
2. Switch fast from e.g. minute 10 to min 75. Then switch back fast to another minute like minute 50 or 40. Do 10 times until it stops loading the track for 10seconds until it plays from this position again.


Actual results:

If you reproduce my steps (i tried it with beta & aurora) you can experience to long playback times if you just want to quick switch between tracks in a mix. It seems Firefox forgets to buffer again from the new position of the mix i clicked.


Expected results:

I tried it with IE11 & Chrome and could not reproduce this problems. There are no long waiting times when fast switching through a soundcloud DJ-Mix.
It is not due my low internet connection (20Mbit down, 5Mbit up).
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64

Updated

2 years ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
I can reproduce a ~1s delay on Firefox 46 on Mac, but not the long playback hang. Something windows-specific?
Priority: -- → P2
Chris - is there a flag to test the WMF backend instead of Direct Show? Can you get someone to have a looksee?
Flags: needinfo?(cpearce)
I could reproduced the bug on Latest Developer Edition 46.0a2 (2016-03-03) on Windows 7, 64 Bit!

Though, it was not reproducible every time, I had to jump from one portion to another for couple of times to reproduce the issue!

Build ID 	20160303004038
User Agent 	Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0

It may be noted, I could not reproduce it in latest Nightly! and I used this track to reproduce the bug - https://soundcloud.com/johnb/john-b-podcast-157-spring-2015-studio-mix
(In reply to Hossain Al Ikram [:ikram] (QA Contact) from comment #3)
> I could reproduced the bug on Latest Developer Edition 46.0a2 (2016-03-03)
> on Windows 7, 64 Bit!

How bad is it? It sounds like it would be difficult to bisect.

Does setting media.directshow.enabled=false make a difference?
Mass change P2 -> P3
Priority: P2 → P3
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #2)
> Chris - is there a flag to test the WMF backend instead of Direct Show? Can
> you get someone to have a looksee?

Turning off WMF (open about:config in the URL bar, search for media.wmf.enabled, and double click to disable) will cause Firefox to use DirectShow for MP3 decoding instead of Windows Media Foundation.

I can only reproduce a problem with seeking taking a few seconds to complete if I turn of WMF. That is, only with DirectShow. It's possible that Jan is testing on a machine with DirectShow but not WMF, though I didn't think such a configuration was possible other than Windows XP.

Jan, if you open a new tab and enter about:config in the URL bar, and then search for media.directshow.enabled and double click it to set it to false, and then reload your john-b podcast, does it still play?
Flags: needinfo?(cpearce) → needinfo?(jan.geeeze)
platform-rel: --- → ?
Whiteboard: [platform-rel-Soundcloud]
platform-rel: ? → -
The DirectShow backend that was causing the issue is no longer available. It was removed along with Windows XP support.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.