Closed Bug 1251965 Opened 4 years ago Closed 4 years ago

[DevTools][Debugger] The Remove Others cannot delete other disable breakpoints

Categories

(DevTools :: Debugger, defect, P1)

45 Branch
defect

Tracking

(firefox45 affected, firefox46 affected, firefox47 fixed)

RESOLVED FIXED
Firefox 47
Tracking Status
firefox45 --- affected
firefox46 --- affected
firefox47 --- fixed

People

(Reporter: magicp.jp, Assigned: jlong)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160228030239

Steps to reproduce:

1. Start Firefox
2. Go to "bugzilla.mozilla.org"
3. Open DevTools > Debugger
4. Select any JS file
5. Add 3 or more breakpoints
6. Select "Disable others" by Right-click menu on the dbg-breakpoint-detail-container
7. Select "Remove others"


Actual results:

The Remove Others cannot delete other disable breakpoints.

Regression range:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=15522bc2931a52ec435f22e233f747264b90f647&tochange=0e47cb06470145725732f0f362c46048969126d8


Expected results:

The Remove Others should delete other disable and enable breakpoints
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Developer Tools: Debugger
Flags: needinfo?(jlong)
OS: Unspecified → All
Hardware: Unspecified → All
Attached patch 1251965.patchSplinter Review
Nice catch!
Flags: needinfo?(jlong)
Assignee: nobody → jlong
Marking this as P1 since it's a UX papercut (and it seems like James is already working on it).
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/39c23264761c
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.