Mozilla 0.9.8 crashes on gkparser at isuzu.co.jp

RESOLVED WORKSFORME

Status

()

Core
HTML: Parser
--
critical
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: u31731, Assigned: harishd)

Tracking

({crash})

Trunk
x86
Windows 95
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Mozilla milestone 0.9.8 crashes upon loading Isuzu Motors' Japan site on Win95
(all Win32?). No Jpn language pack installed. Talkback ID is: TB2848113K.
Crashes consistently everytime. URL is http://www.isuzu.co.jp/ .

Steps to reproduce:
1. Load the website referenced above.
2. Watch Mozilla crash (GKPARSER.DLL).

Expected results:
Moz (en-US) should attempt to load page and prompt for language pack/plugin
download. Please ignore my custom user-agent (it's masked as Netscape 6 for
tracking reasons).

Comment 1

17 years ago
Reporter: Please always use severity level "critical" for crashes.

Comment 2

17 years ago
WFM (and I see a lot of Japanese characters). Build ID: 2002 02 12 03. Windows 2000.

Comment 3

17 years ago
Works for me on 2002021203 WinME, but I already have Japanese fonts installed.
Severity: major → critical
Keywords: crash, stackwanted
Stack Signature  little2_updatePosition 6e337417
Trigger Time 2002-02-13 02:23:54
Email Address
URL visited www.isuzu.co.jp
Build ID 2002020409
Product ID MozillaBranch
Platform
Operating System Win32
Module
Trigger Reason Access violation
User Comments Loading Isuzu Motors Japan site with Mozilla 0.9.8.
Stack Trace
little2_updatePosition [d:\builds\seamonkey\mozilla\expat\xmltok\xmltok_impl.c,
line 1735]
XML_GetCurrentColumnNumber
[d:\builds\seamonkey\mozilla\expat\xmlparse\xmlparse.c, line 1044]
nsAString::AppendFromReadable
[d:\builds\seamonkey\mozilla\string\src\nsAString.cpp, line 326]
nsExpatDriver::ParseBuffer
[d:\builds\seamonkey\mozilla\htmlparser\src\nsExpatDriver.cpp, line 634]
nsExpatDriver::ConsumeToken
[d:\builds\seamonkey\mozilla\htmlparser\src\nsExpatDriver.cpp, line 739]
nsParser::Tokenize [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 2589]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1847]
nsParser::ContinueParsing
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1497]
CSSLoaderImpl::Cleanup
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 813]
CSSLoaderImpl::SheetComplete
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 920]
CSSLoaderImpl::ParseSheet
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 955]
CSSLoaderImpl::DidLoadStyle
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 991]
SheetLoadData::OnStreamComplete
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 751]
nsStreamLoader::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamLoader.cpp, line 163]
nsJARChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\jar\src\nsJARChannel.cpp, line 614]
nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 213]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072] 

Try a trunk build
Keywords: stackwanted

Comment 5

17 years ago
WFM with build 2002020405 Mac OS 9.1
(Reporter)

Comment 6

17 years ago
Created attachment 69426 [details]
Screenshot of crash in action
(Reporter)

Comment 7

17 years ago
FWIW: I have set to disallow unrequested new windows in Scripts & Windows pref,
allow all cookies (but warn first), open new windows in a tab, and using modern
theme. Don't know if this is related, just some FYI stuff. Still crashes
everytime (adding screenshot). Can someone test this on the Win32 (preferably
Win95 -yeah I know it's old) 0.9.8 milestone?

Comment 8

17 years ago
I get same crash at http://fae.abit.com.tw/eng/
See talkback IDs TB3516873G & TB3516742Y.
Using 0.9.8 on WinME.
This is probably a regression, as I used to be able to open this page. But then
again, the page may have changed.
My error window said that Moz caused an error in GKPARSER.DLL.

Comment 9

17 years ago
works for me 20020302 on win2k
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 10

17 years ago
How can this be resolved WFM? Two different reporters have the behavior and sent
TBIDs. The crash was repeatable.

Note I am using WinME, not Win95.

I installed Chinese and Japanese lang/content packs, and the crash completely
stopped occurring at the URL I provided. Does that help?
reopening - Gemal has not installed all languga packs.
Can someone please try a recent nightly build (0.9.8 is old) ?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 12

17 years ago
I will retry when 0.9.9 is released. I stopped installing nightlies because they
take too long to download at home (and have been too buggy to use) and because
they interfere with my work at work. 

Are lang packs installed in the users profile or on the program file side? (That
is, if I do a "clean" install, except saving my profile, will the lang packs be
gone?

This was a nasty crash. Thanks for reopening - I'll let you know.
(Assignee)

Comment 13

17 years ago
This is definitely a dup of bug 123475. It's fixed on the tip. Please try this
on the latest builds. Thanks.

Comment 14

17 years ago
While waiting for 0.9.9 to release :-(, I got this crash again at
http://fae.abit.com.tw/eng/. Somehow, langpacks had uninstalled (I might have
tried a later build, unistalled, and reinstalled 0.9.8). Installed JP langpack,
still crashed. Installed simplified chinese, still crashed. Installed
traditional chinese, no crash.

TB IDs TB3905685Y & TB3905905E

Comment 15

17 years ago
This now WFM with 0.9.9 installed. Both WinME and Win98SE. Thanks for your patience!
(Reporter)

Comment 16

17 years ago
I'll download 0.9.9 as well to see if it WFM, too. It still crashed on some
0.9.9- nightlies.

Comment 17

16 years ago
WFM with 2002040403 under Win95 with and without Language Support.

If without Language Support mozilla asks rightly for downloading support file.
After installing and without win restart it is usable (The view changes imeditly).

Should be closed.
Resolving WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.