[e10s] crash in mozalloc_abort | Abort | NS_DebugBreak | mozilla::dom::PSpeechSynthesisRequestParent::SendOnBoundary

RESOLVED WORKSFORME

Status

()

Core
Web Speech
--
critical
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: adalucinet, Unassigned)

Tracking

({crash})

Trunk
x86_64
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(e10s+, firefox45 affected, firefox46 affected, firefox47 unaffected)

Details

(crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-6989594b-898b-4baa-a8f9-10c6a2160229.
=============================================================
Affected versions: 
* 45 beta 10 (Build ID: 20160225145837) e10s *enabled* ('browser.tabs.remote.autostart' set to true)
* latest Aurora 46.0a2 (from 2016-02-28) e10s *enabled* → bp-bd7b2769-7a5b-4234-85a2-3e6cc2160229

Affected platforms: Mac OS X 10.11.1, Mac OS X 10.9.5

Prerequisites: 'media.webspeech.synth.enabled' pref is set to true via about:config page		

Steps to reproduce:
1. Launch Firefox and navigate to http://codepen.io/matt-west/pen/wGzuJ
2. Type some long text and click the "Speak" button.
3. While the sound is on, restart Firefox via Developer Toolbar - open the Developer Toolbar (Shift+F2), type 'restart' and hit Enter.

Additional notes:
1. With 45 beta 10, e10s disabled, encountered crash bug 1252048.
2. Apparently, something from the below pushlog [1] fixed this issue on Nightly 47.0a1 starting with 2016-02-10 build.

[1] https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d1a54ae63da7&tochange=ac39fba33c6d
(Reporter)

Updated

2 years ago
See Also: → bug 1252048

Updated

2 years ago
tracking-e10s: --- → +
Because the pref in question ('media.webspeech.synth.enabled') is held on Nightly, and this has apparently been fixed on Nightly (see comment 0, Additional notes #2) by something since 2016-02-10 (also per comment 0).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.