Cannot setup Passcode if you have no logins saved

RESOLVED FIXED

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: st3fan, Assigned: sleroux)

Tracking

unspecified
All
iOS

Firefox Tracking Flags

(fxios-v3.0 fixed, fxios3.0+)

Details

(Reporter)

Description

3 years ago
If the logins database is empty, it is not possible to set a passcode.

Updated

3 years ago
Blocks: 1198418
(Reporter)

Updated

3 years ago
tracking-fxios: ? → 3.0+
(Assignee)

Comment 1

3 years ago
I just tried to do this after removing FF from my simulator but was able to setup my passcode fine. I did notice however that after removing FF from the simulator, when I went into the Touch ID/Passcode settings screen, it was already enabled since it was cached in the keychain. After resetting the simulator's contents everything was fine. Do you have a STR?
Flags: needinfo?(sarentz)
I don't have STR, but I've ran into this issue and managed to grab a log

https://pastebin.mozilla.org/8862590
(Assignee)

Comment 3

3 years ago
When selecting 'Turn Passcode On', does the passcode screen show? Also, if it shows, is the keyboard not showing at all? Or are you able to enter a passcode but it doesn't save and has no effect?
Flags: needinfo?(catalin.suciu)
I'm able to enter the passcode but has no effect.
Flags: needinfo?(catalin.suciu)
(Assignee)

Updated

3 years ago
Assignee: nobody → sleroux
Status: NEW → ASSIGNED
(Assignee)

Comment 5

3 years ago
Looking at the logs, it shows that the keyboard appeared for passcode input, a few seconds went by, and a bunch of the following errors appeared:

> Mar  7 15:33:44 Catas-iPhone securityd[3596] <Error>:  secTaskDiagnoseEntitlements MISSING keychain entitlements: original ag: (null)
> Mar  7 15:33:44 Catas-iPhone securityd[3596] <Error>:  secTaskDiagnoseEntitlements MISSING keychain entitlements: newly parsed ag: (null)
> Mar  7 15:33:44 Catas-iPhone securityd[3596] <Error>:  __security_simulatecrash Simulating crash, reason: keychain entitlement(s) missing, code=53c00007
> Mar  7 15:33:44 Catas-iPhone securityd[3596] <Error>:  securityd_xpc_dictionary_handler Client[5245] add Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}

From the delay and keyboard showing up, it looks like you tried entering the passcode but it never was able to be saved because the keychain rejected the change as shown from the error above. This error would make sense if this was reproducible 100% of the time because it relates to how we sign the build but its very confusing that it only happens periodically.

I did, however, stumble across this lovely thread which seems similar to the situation we're seeing here: https://forums.developer.apple.com/thread/4743

An potential workaround they suggest is to delay accessing the Keychain until after didLaunchWithOptions. Currently we touch the Keychain whenever we setup profile on app launch so we would have to investigate moving those parts out of the Profile initialization.

Besides that I'm not sure what else could be going on.
(Reporter)

Comment 6

3 years ago
This now works fine for me on the last 3.0 TF build.
Flags: needinfo?(sarentz)
(Assignee)

Comment 7

3 years ago
Hey Catalin, do you mind trying to see if you can reproduce this in the latest TF build (3.0b6)? The error looks like something that could have been solved behind the scenes related to how the app is signed but want to make sure that this is no longer an issue since I know it's not reproducible 100% of the time.
Flags: needinfo?(catalin.suciu)
So far I was not able to reproduce this issue on 3.0b6/3.0b7.
Status: ASSIGNED → NEW
Flags: needinfo?(catalin.suciu)
Component: General → Login Management
Hardware: Other → All
(Assignee)

Comment 9

3 years ago
I'm going to go ahead and mark this as resolved. Feel free to reopen if it causes issues. Thanks for the test!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-fxios-v3.0: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.