Mozilla hangs after reading v-card

RESOLVED WORKSFORME

Status

MailNews Core
Backend
--
critical
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Mirko Zeibig, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

After trying to read a mail with a special (invalid) v-card Mozilla hangs.

Reproducible: Always
Steps to Reproduce:
1. Create a mail with the following v-card attachment:
begin:vcard
x-mozilla-html:FALSE
adr:;;;;;;
version:2.1
PHOTO;ENCODING=BASE64;TYPE=GIF:
R0lGODdhfgA4AOYAAAAAAK+vr62trVIxa6WlpZ+fnzEpCEpzlAha/0Kc74+PjyGM
SuecKRhrtX9/fzExORBSjCEYCGtra2NjYyF7nDGE50JrhAg51qWtOTl7vee1MWu1
50o5e3PO/3sxcwAx/4R7GBgQOcDAwFoAQt61hJyMGHuUSpRKIf8A/wAY54yMjHtz
end:vcard
2. send this mail to someone
3. try to open (or delete) this mail


Actual Results:  Mozilla hangs

Expected Results:  Open the mail and show the v-card without the photo or
display a errormessage.


The problem is the invalid PHOTO-entry. Other mailclients (Netscape) have the
same problem. You can use this problem as a simple DoS to someones mailclient ;)

Comment 1

16 years ago
I was not able to confirm this bug on build 2002100808. I did a telnet to my
mail server's sendmail port (usually 25) and pasted the following text. I was
able to view the mail in Messenger, although the VCARD didn't display in the
window. Maybe there is something wrong with the test data provided?

mail from:pmularien@_nospam_deploy.com
rcpt to:pmularien@_nospam_deploy.com
data
Subject: Test bug 125209 
Content-Type: multipart/mixed;
	boundary="----=_NextPart_000_0302_01C263CB.5EFBB3E0"


This is a multi-part message in MIME format.

------=_NextPart_000_0302_01C263CB.5EFBB3E0
Content-Type: multipart/alternative;
	boundary="----=_NextPart_001_0303_01C263CB.5EFBB3E0"


------=_NextPart_001_0303_01C263CB.5EFBB3E0
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable


test mozilla bug 125209

------=_NextPart_001_0303_01C263CB.5EFBB3E0--

------=_NextPart_000_0302_01C263CB.5EFBB3E0
Content-Type: text/x-vcard;
	name="test.vcf"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: attachment;
	filename="test.vcf"

begin:vcard
x-mozilla-html:FALSE
adr:;;;;;;
version:2.1
PHOTO;ENCODING=BASE64;TYPE=GIF:
R0lGODdhfgA4AOYAAAAAAK+vr62trVIxa6WlpZ+fnzEpCEpzlAha/0Kc74+PjyGM
SuecKRhrtX9/fzExORBSjCEYCGtra2NjYyF7nDGE50JrhAg51qWtOTl7vee1MWu1
50o5e3PO/3sxcwAx/4R7GBgQOcDAwFoAQt61hJyMGHuUSpRKIf8A/wAY54yMjHtz
end:vcard

------=_NextPart_000_0302_01C263CB.5EFBB3E0--


.
Reporter, as a test could you please create a mail with such an invalid v-card 
and send it to me at admin@mozillatranslator.org ?

btw. please also send a plain warning mail in advance ;-)

Comment 3

16 years ago
Reporter, is this still happening with a recent version? If so, please attach a
test mail to this bug.

pi

Comment 4

16 years ago
I was able to reproduce this bug on build 2003011408 (win 2000) by doing the
following

1. create the vcf file by pasting the above in a txt file and saving as vcf
2. attaching the fake vcf file to an email
3. send the email
4. try to open email after it is received


additionally, if you restart mozilla mail after crash and try to select the
message with the bogus vcf, it will crash again.

Comment 5

16 years ago
still able to reproduce bug on build 2003011508

Comment 6

16 years ago
Please attach to this bug a mailfile with a message that makes you hang or crash.

pi

Comment 7

16 years ago
Created attachment 115366 [details]
Testcase from comment 1

Importing the attached mail does not cause a problem for me. Mozilla 1.3b
release on Linux does not crash. I cannot view the attached v-card, though.

pi

Comment 8

16 years ago
Since there was no answer to my request to provide a problematic message anyway,
I mark this as WFM.

pi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.