The Text inside options and optgroups can be selected

VERIFIED FIXED in M14

Status

()

defect
P3
normal
VERIFIED FIXED
20 years ago
3 years ago

People

(Reporter: rods, Assigned: rods)

Tracking

Trunk
x86
Windows NT
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Text selection need to be turned off for option and optgroups
Depends on: 12520
[Ah, I was actually going to ask Akkana yesterday whether this was a bug or not.
;-]
I'm not sure how you saw text selection in option elements yesterday because
they worked fine as far as I know. It was my check in this morning that broke
it.
Hey, Rod ---

Sure. Let's see if we're talking about the same thing; I used the 1999082412
build for Mac OS. If you:
	- go to http://slip/projects/marvin/copy-paste/copy-bad-stuff/copy-bad-
stuff.html
	- select the entire page contents, copy, and go to the Clipboard

...the following Bad Things will have happened:

	- the text labels from the Submit and Reset buttons were selected (but at
least not copied to the Clipboard)
	- (as I believe you describe here), the selected OPTION item ("A
bit'o'random text") will be copied to the Clipboard.

Is this the same thing that we're both talking about, or should I break this into
a separate bug report? Thanks!
What you just described is very closely related, but more general. It might be
good to have it as a separate bug.
[Broke related issue(s) raised into bug #12560.]
*** Bug 12661 has been marked as a duplicate of this bug. ***
*** Bug 15921 has been marked as a duplicate of this bug. ***
QA Contact: phillip → elig
QA Assigning to self.
Build ID: 1999111612 (M11)
Platform: Macintosh PowerBook G3/300, MacOS 9, 128Mb RAM, VM off.

I've found an odd behavior related to this bug. Not sure if it's been reported
before. Try the following:

http://bugzilla.mozilla.org/

 Select "Query Existing Bug Reports." Under Platform, click Macintosh. Press
&hold shift key down. Under Status, click "Resolved." Note that every item in
every select list between Macintosh and Resolved has been selected.
Yes, this is the correct behavior on Windows, and there is abug files against it
for the Mac. The problem is partically the select lement's select code and
partically keybinding work.
After fixing bug 12520, I though it would be really easy to fix that one too. I
tried a bit and gave up after checking in a partial fix in html.css v3.25. With
my fix, you can no longer start the selection from within the list but if you
click on top of the page and drag to the bottom, the text within the list is
still selected. I could not fix it just by playing with html.css: maybe I did not
look deep enough, maybe it's elsewhere... Anyhow I already did more than my
share, it's your turn now.
changed to M14
*** Bug 21491 has been marked as a duplicate of this bug. ***
*** Bug 18945 has been marked as a duplicate of this bug. ***
*** Bug 22477 has been marked as a duplicate of this bug. ***
*** Bug 22618 has been marked as a duplicate of this bug. ***
*** Bug 23287 has been marked as a duplicate of this bug. ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
tested - This now is fixed because 12520 is fixed.
Verified fixed using 2000021008 builds on Mac OS 8.6, NT 4.0 SP5 & RH Linux 6.0/
GNOME.

(Specifically, checked every duplicate of this bug, and wrote up a few related-
ish bugs discovered in process of verifying.)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.