Carthage 0.15 failure: lipo: -remove i386 specified but fat file: .../DWARF/WebImage does not contain that architecture

RESOLVED DUPLICATE of bug 1252255

Status

()

RESOLVED DUPLICATE of bug 1252255
3 years ago
3 years ago

People

(Reporter: st3fan, Unassigned)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios3.0+)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

3 years ago
fatal error: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/lipo: -remove i386 specified but fat file: /Users/sarentz/Library/Developer/Xcode/DerivedData/Client-awmzgkgtcmxgnmfytuwcisolbdou/Build/Products/Debug-iphoneos/WebImage.framework.dSYM/Contents/Resources/DWARF/WebImage does not contain that architecture
(Reporter)

Comment 1

3 years ago
This is the blocker that prevents us from using Carthage > 0.11
(Reporter)

Comment 2

3 years ago
Created attachment 8724897 [details] [review]
PR: https://github.com/mozilla/firefox-ios/pull/1583

This patch does two things:

* It disabled `parallelizeBuildables` in all the application schemes - This works around the issues we are having with Carthage
* It changes the Carthage version check to 0.15 instead of 0.11

I restructured the `carthage.sh`, `checkout.sh` and `update.sh` scripts a bit. I don't think they worked correctly. They would still continue if the `carthage.sh` check failed. The `carthage.sh` script now just fails and it does not automatically install carthage. Instead it will point the user to our `BUILD.md` page. (Which we need to update if this lands)
Attachment #8724897 - Flags: review?(sleroux)
Attachment #8724897 - Flags: review?(etoop)
(Reporter)

Updated

3 years ago
Attachment #8724897 - Attachment is obsolete: true
Attachment #8724897 - Flags: review?(sleroux)
Attachment #8724897 - Flags: review?(etoop)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1252255
You need to log in before you can comment on or make changes to this bug.