onmouseover and CSS hover conflict - Worked on 0.9.7, doesn't on 0.9.8

RESOLVED DUPLICATE of bug 38380

Status

()

RESOLVED DUPLICATE of bug 38380
17 years ago
5 years ago

People

(Reporter: pedro.alves, Assigned: jag-mozilla)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
This piece of HTML code should swap "Teste" to red when the mouse is over the
link. Does not work, allthough the status line changes. If I change the function
to onmouseover="window.status='Teste'" (without the return true), the css works
but does not change the status bar. In 0.9.7, the css worked but the status did
not change. Here is the code:

<html><head>
<style type="text/css">
a{color : blue; }
a.menulogin:active{ color : red;}
a.menulogin:hover { color : red;}
</style>
<body bgcolor="#eeeeee">

<table width="100%">
<tr><td class="menulogin"><a class="menulogin" href="#"
onmouseover="window.status='Teste'; return true"
onmouseout="window.status='out'" >Teste</a></td></tr><tr></tr>
</table>
</body></html>
*** Bug 125220 has been marked as a duplicate of this bug. ***

Comment 2

17 years ago
Created attachment 69256 [details]
1st test case

Comment 3

17 years ago
verified win 2k build # 2002020406

Comment 4

17 years ago
over to Style System.  adding testcase keyword.

I see the reporter's expected behavior on 2001112203 but not on 2002012803.  I
don't know if this is a dupe or an intentional behavior so adding DUPME to
status whiteboard.
URL: embebed
Status: UNCONFIRMED → NEW
Component: Browser-General → Style System
Ever confirmed: true
Keywords: testcase
Whiteboard: DUPME

Comment 5

17 years ago
iirc this was an intentional change.
Assignee: asa → jaggernaut
Component: Style System → DOM Level 0
QA Contact: doronr → desale
Whiteboard: DUPME → DUPEME
Duplicate of '[ESM/CSS] css a:hover ignored on link with javascript
"onMouseover" and "return true;"'

*** This bug has been marked as a duplicate of 38380 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.