Closed Bug 1252305 Opened 4 years ago Closed 4 years ago

Tabs flow below toolbar if a toolbarbutton type="menu-button" is in the tabbar-toolbar

Categories

(Thunderbird :: Theme, defect)

x86_64
Linux
defect
Not set

Tracking

(thunderbird46 fixed, thunderbird47 fixed, thunderbird_esr45 fixed)

RESOLVED FIXED
Thunderbird 48.0
Tracking Status
thunderbird46 --- fixed
thunderbird47 --- fixed
thunderbird_esr45 --- fixed

People

(Reporter: alta88, Assigned: Paenglab)

Details

Attachments

(1 file)

Customizing and placing the print button, for example, in the tabs toolbar will cause the toolbar to shrink, and tab borders flow outside the tabs toolbar.
Attached patch dropmarker.patchSplinter Review
My bad, I should have to check also the toolbarbuttons when I fixed the menulist dropmarker.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8725286 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8725286 [details] [diff] [review]
dropmarker.patch

Review of attachment 8725286 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, r=mkmelin
Attachment #8725286 - Flags: review?(mkmelin+mozilla) → review+
Keywords: checkin-needed
Comment on attachment 8725286 [details] [diff] [review]
dropmarker.patch

Not sure when c-c reopens, so adding the approval now

[Approval Request Comment]
Regression caused by (bug #): 1244570 which is in TB 45
User impact if declined: tabs not correctly connected to the toolbar
Testing completed (on c-c, etc.): not yet
Risk to taking this patch (and alternatives if risky): low
Attachment #8725286 - Flags: approval-comm-esr38?
Attachment #8725286 - Flags: approval-comm-beta?
Attachment #8725286 - Flags: approval-comm-aurora?
With c-c closed but close to releases, let's land this in aurora.
Comment on attachment 8725286 [details] [diff] [review]
dropmarker.patch

Pushed to aurora as pretest for TB 45 checkin since c-c is closed:

http://hg.mozilla.org/releases/comm-aurora/rev/511f19bc675a
Attachment #8725286 - Flags: approval-comm-aurora? → approval-comm-aurora+
Target Milestone: --- → Thunderbird 48.0
Comment on attachment 8725286 [details] [diff] [review]
dropmarker.patch

(I believe you meant esr45 and not esr38)

http://hg.mozilla.org/releases/comm-esr45/rev/f2cd3d2e2b69
http://hg.mozilla.org/releases/comm-beta/rev/151317bf1995
Attachment #8725286 - Flags: approval-comm-esr45+
Attachment #8725286 - Flags: approval-comm-esr38?
Attachment #8725286 - Flags: approval-comm-beta?
Attachment #8725286 - Flags: approval-comm-beta+
https://hg.mozilla.org/comm-central/rev/902f0f9fcdc14f1858a768e52512bca7aca94c65
Bug 1252305 - Use a background image for the .toolbarbutton-menubutton-dropmarker. r=mkmelin
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.