If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Constant and repeatable crashes

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: VOLANS2000, Unassigned)

Tracking

44 Branch
x86_64
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160211124446

Steps to reproduce:

My PC is a netbook with up to date Fedora. I also use it on windows XP in a different computer and no problem there.

- Login on Facebook.
- On the initial page, keep sliding down.
- Firefox eventually acts like you had cutoff the internet connection (loading page behaviour).
- Eventually, you close the firefox window, but it keeps running on background.
- If you open System Monitor, you'll see it's still running and consuming increased amounts of RAM.
- After around 5 minutes it crashes. And automatic file bug is sent and that's it.



Actual results:

All described above.


Expected results:

Constant crashes, everytime you make the steps I wrote.
(Reporter)

Updated

2 years ago
OS: Unspecified → Other
Hardware: Unspecified → x86_64
Hi reporter,

I haven't managed to reproduce this issue on the latest release(44.0.2) nor latest Nightly(47.0a1). I've tested your scenario on Fedora 23. Scrolling down on Facebook didn't crash Firefox. It may be related to your internet connection speed, since Facebook stops loading new pages. Does this happen in other browsers?

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160302030209

Can you please try to reproduce this on the latest release(44.0.2) and latest Nightly(47.0a1) and provide the results? When doing this, please try to reproduce with a new clean Firefox profile, maybe even in safe mode, as some of this issues may be caused by third party installed add-ons or custom settings(https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems).

Thanks,
Paul.
Flags: needinfo?(VOLANS2000)
(Reporter)

Comment 2

2 years ago
Hello, thanks for your interest on the problem.

My internet connection is good and stable and all other programs work fine. Just Firefox was crashing. However, after an update I did the day after I filed the bug, in which Firefox WASN'T among the updated packages, it didn't crash anymore. Perhaps it was a bug in another Linux component, that interfered with Firefox.

Murphy's law: the day you file a bug, it dissapears!
Flags: needinfo?(VOLANS2000)
Hi reporter,

Considering last comment, I will mark this issue as RESOLVED WORKSFORME. If you still encounter this problem, please feel free to reopen this bug, or file a new one.

Thanks,
Paul.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

2 years ago
OK, after another computer update, the bug is back! I didn't take a look on the updates applied, so I am not sure if Firefox was updated this time. However, same symptoms returned.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 5

2 years ago
Created attachment 8728743 [details]
Captura de ecrã de 2016-03-10 01-50-21.png

A screencapture of Firefox process, during the crash process. You can see it's consuming huge amounts of memory (more than 500MB) and 47% of CPU.

I think it's some issue with some script that runs inside Facebook, because if I press the 'Close' button of Firefox, it still asks me normaly if I want to close all the tabs, meaning it's still responsive. This problem however only happens in Firefox, not with Chrome that I also have.
Hi reporter,

Can you please provide a crash signature? If you type about:crashes in the URL bar, you will see all crashes you had on your current profile. Also, does a new profile or safe mode make any difference?

Thanks,
Paul.
Flags: needinfo?(VOLANS2000)
(Reporter)

Comment 7

2 years ago
Sorry. Since the last message, the bug never repeated again. Probably some update fixed it. I'm going to change the state to 'Closed'.
Flags: needinfo?(VOLANS2000)
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.