Status

()

RESOLVED DUPLICATE of bug 1061233
3 years ago
3 years ago

People

(Reporter: Pike, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
dkl looked into a slow webservice query for me, and tracked the perf problems down to _bug_to_hash, profile's up on https://hardison.net/~dylan/nytprof3/opt-bugzilla-Bugzilla-WebService-Bug-pm-580-line.html#1337.

Might need more fields to be treated like bug 1039940?

Query is 

https://bugzilla.mozilla.org/rest/bug?status_whiteboard=[transvision-feedback]&include_fields=resolution,whiteboard,id,component

and yes, I'm interested in all of them. It's "just" 280 bugs, and it takes 6-8 seconds for the data to return. dkl tested the query itself only took about a second of that time.

Filing this to turn profile into action :-)
this is probably a duplicate of bug 1061233.
I'm not dkl, also. I'm dylan :-)
after pondering, i'm marking this as a duplicate of bug 1061233.

the important fields were caught by bug 1039940, further improvements need a much heavier hammer.

regarding the wip patch on bug 1061233:
> without custom field support i've managed to reduce the time it takes to
> serialise about 9700 bug objects from 18 seconds to less than 1 second.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1061233
You need to log in before you can comment on or make changes to this bug.