Closed Bug 1252519 Opened 5 years ago Closed 5 years ago

specify compatible version range in runtime error about Firefox not being found

Categories

(Firefox Graveyard :: Webapp Runtime, defect)

defect
Not set
normal

Tracking

(firefox47 fixed)

RESOLVED FIXED
Firefox 47
Tracking Status
firefox47 --- fixed

People

(Reporter: myk, Assigned: myk)

References

Details

Attachments

(2 files, 1 obsolete file)

Attached patch specify compatible version range (obsolete) — Splinter Review
Since we're planning to display a warning message about the desktop runtime being disabled (bug 1245204), we have an opportunity to also update the error message that the runtime stub displays when it can't find a compatible version of Firefox.

This patch changes the message from:

  This app requires that Firefox version 16 or above is installed.
  Firefox 16+ has not been detected.

To:

  This app requires that Firefox version 16 - 47 is installed.
  A compatible version of Firefox has not been detected.
Attachment #8725323 - Flags: review?(mcastelluccio)
Minor wordsmithing update:

  This app requires Firefox version 16 - 47 to be installed.
  No compatible version of Firefox has been detected.
Attachment #8725323 - Attachment is obsolete: true
Attachment #8725323 - Flags: review?(mcastelluccio)
Attachment #8725332 - Flags: review?(mcastelluccio)
Comment on attachment 8725332 [details] [diff] [review]
specify compatible version range

Review of attachment 8725332 [details] [diff] [review]:
-----------------------------------------------------------------

Nit: Could we make the message clearer? "a Firefox version between 16 and 47" or something like that.
Attachment #8725332 - Flags: review?(mcastelluccio) → review+
(In reply to Marco Castelluccio [:marco] from comment #2)
> Nit: Could we make the message clearer? "a Firefox version between 16 and
> 47" or something like that.

Yes, this patch uses your suggested wording.  This is the version I'll commit.
https://hg.mozilla.org/mozilla-central/rev/dea50f252713
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.