Plugin fails to load with error "undefined symbol: xmDrawingAreaWidgetClass"

VERIFIED WORKSFORME

Status

()

Core
Plug-ins
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Dave, Assigned: serge (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020209
BuildID:    2002020921

I have to install the Citrix ICA plugin (http://www.citrix.com) in order to run
an application here at work. I downloaded the tarball and ran the install script
(as root), which completed successfully. (installing in /usr/lib). I then
proceeded to create a symlink to the .so file from my $MOZILLA_HOME/plugins
directory and upon starting the browser, got the following error:

LoadPlugin: failed to initialize shared library /usr/lib/ICAClient/npica.so
[/usr/lib/ICAClient/npica.so: undefined symbol: xmDrawingAreaWidgetClass]

which got printed again when I visited the page that used the plugin.

After this failed to work, I created the symlink in netscape's plugins directory
and ran it and about:plugins listed the plugin like it was supposed to and the
plugin works as well as a plugin meant for windows ever can work under unix.

Reproducible: Always
Steps to Reproduce:
1. Download and install aforementioned plugin
2. create symlink to .so file in mozilla's plugins directory
3. restart browser and notice that plugin fails to load.
4. Visit page that uses plugin and notice that it really didn't load (the page I
used is internal... sorry).

Actual Results:  Browser reports that plugin failed to load and plugin doesn't work.

Expected Results:  Plugin should load and work

Works with NS4.7

Comment 1

16 years ago
-->serge
Assignee: av → serge
(Assignee)

Comment 2

16 years ago
if you have motif installed 
just make sure the next line in prefs.js file looks like, 
user_pref("plugin.soname.list", "libXt.so:libXext.so:libXm.so");
(Reporter)

Comment 3

16 years ago
That was it. prefs.js had that line, only sans libXm.so. I.e. it said:

user_pref("plugin.soname.list", "libXt.so:libXext.so");

and libXm.so just happens to be what my motif lib is called... I guess I just
hadn't updated my profile since that file was added to the plugin list.
(Assignee)

Comment 4

16 years ago
resolving as WFM
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

16 years ago
vrfy, assuming that the missing "libXm.so" entry is something that has been
fixed recently.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.