Using IME, Kanji suggestion box is rendered at the wrong place

RESOLVED WORKSFORME

Status

()

Core
Widget: Win32
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Nicolas, Unassigned)

Tracking

({inputmethod})

44 Branch
x86_64
Windows 10
inputmethod
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8725427 [details]
bug_kanji-firefox.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

Steps to reproduce:

Using any japanese IME on windows

1. Open a new google document
2. Type in any letter


Actual results:

The suggestion box has an offset when rendering for the first, but does work correctly. Once it is used though, the input simply gets broken + it sends the box in the bottom left corner.


Expected results:

Suggestion box should appear underneath the cursor, like it does in any other text field.

Comment 1

2 years ago
T'as utilisé quel IME (je suis sur Win 7) pour taper du texte dans GG Doc ?
J'ai mis Japonais puis l'IME Microsoft, mais ça continue de taper en latin azerty ou qwerty.
Flags: needinfo?(nicolas.rouleau08)

Updated

2 years ago
Component: Untriaged → Widget: Win32
Keywords: inputmethod
Product: Firefox → Core
(Reporter)

Updated

2 years ago
Flags: needinfo?(nicolas.rouleau08)
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
(Reporter)

Comment 2

2 years ago
(In reply to Loic from comment #1)
> T'as utilisé quel IME (je suis sur Win 7) pour taper du texte dans GG Doc ?
> J'ai mis Japonais puis l'IME Microsoft, mais ça continue de taper en latin
> azerty ou qwerty.


Windows 10 et ça se produit autant avec le Google IME que celui de Microsoft.
I have some questions.
- Firefox 44 or early has several issues on Google Docs.  Could you test this on the Nightly (version 47)?
- If trying 47, could you reproduce this on both e10s or non-e10s?  (If you don't make sense e10s mode, please ignore this question)
- Do you use HiDPI mode?
Flags: needinfo?(nicolas.rouleau08)
(Reporter)

Comment 4

2 years ago
Everything seems A1 when using the nightly build. So far so good at least!

And yes, I was using Win10 scaling (175%)

Thanks!
Flags: needinfo?(nicolas.rouleau08)
close as WFM per comment #4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.