can't send mail to port other than 25

VERIFIED DUPLICATE of bug 52330

Status

MailNews Core
Networking: SMTP
VERIFIED DUPLICATE of bug 52330
16 years ago
9 years ago

People

(Reporter: Jurgen Botz, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205
BuildID:    0.9.8

I use Ssh forwarding to get into my employer's network
for mail reading via IMAP and sending via SMTP.  But
sending via SMTP over forwarded connection doesn't work
because Mozilla ignores smtp port config.  I have the
following line in my prefs.js (I'm not sure anymore where
I found this originally or if it ever worked).

user_pref("mail.smtpserver.smtp1.port", 10025);

Mozilla seems to ignore this as mail goes out via my local
sendmail on port 25.  I didn't notice this for a long time
as it's only a problem when I try to send to some company
mailing lists that can only be reached from my company's 
internal network.



Reproducible: Always
Steps to Reproduce:
1. set up an ssh forwarded connection to some other mail server, i.e. "ssh -L
10025:smtp.someco.com:25 somehost.someco.com"

2. put this line in your prefs.js
user_pref("mail.smtpserver.smtp1.port", 10025);

3. send some mail and check your logs or the 'Received' headers to see where it
actually went



Actual Results:  goes out via my local sendmail on port 25

Expected Results:  should never hit my local sendmail, instead go to smtp relay
at my company.

Comment 1

16 years ago
dup of  52330
  Support non-default SMTP Port

*** This bug has been marked as a duplicate of 52330 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified Duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.