All the content of a form inside a IFRAME is shifted to the left in Mozilla 0.9.8

VERIFIED DUPLICATE of bug 122966

Status

()

--
major
VERIFIED DUPLICATE of bug 122966
17 years ago
17 years ago

People

(Reporter: juarez_jc, Assigned: john)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0; T312461; 
Q312461; .NET CLR 1.0.3705)
BuildID:    2002020406

When a function is called by the click of a buttom inside a iframe all the 
content of the iframe is shifted to the left.
Occurs in Windows and Mac.


Reproducible: Always
Steps to Reproduce:
1.Save the two files bellow (File1.htm and File2.htm).
2.Load the File1.htm in Mozilla 0.9.8 Win or Mac
3.Click the "OK" buttom
4.All the contente of the form is shifted to the left. The "OK" function is not 
called.
5.Click the "OK" buttom again. The "OK" function is called.
6.Load the File1.htm again.
7.Press the Enter key. The function "OK" is called. No shift to the left.


--------------- File1.htm --------------------
<html>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 
4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<body style='margin:0px;background-color:#ffffff;overflow:hidden;'>
	<iframe id='frProgramas' name='wProgramas' frameborder='1' 
FRAMESPACING='0' NORESIZE='NORESIZE' SCROLLING='no' 
style='position:absolute;top:50px;left:150px;width:500px;height:400px;' 
src='File2.htm'></iframe>
</body>
</html>

--------------- File2.htm --------------------
<html>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 
4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<head>
<script>
function OK()
{
	alert("");
}
</script>
</head>
<body onkeyup='if(event.keyCode == 13) OK();'>
<center>
	<FORM NAME='formDados' ACTION='File3.asp' METHOD=POST>
		<table cellspacing=0 cellpadding=0 border=1>
			<TR>
				<TD ALIGN=RIGHT>Agência:&nbsp;</td>
				<TD><INPUT NAME="Agencia" TYPE=TEXT SIZE=4 
MAXLENGTH=4 VALUE=''></td>
			<TR>
				<TD ALIGN=RIGHT>Conta:&nbsp;</td>
				<TD><INPUT NAME="Conta" TYPE=TEXT SIZE=11 
MAXLENGTH=10 VALUE=''></td>
			<TR>
				<TD ALIGN=RIGHT>Senha:&nbsp;</td>
				<TD><INPUT NAME="Senha" TYPE=PASSWORD SIZE=6 
MAXLENGTH=6 VALUE=''></td>
		</table><p>
		<input type='button' value='OK' onclick='OK();'><p>
	</FORM>
</body>
Yet another scrolling="no" bug....
Blocks: 124431
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
 Dupe of bug # 122966

*** This bug has been marked as a duplicate of 122966 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
 verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.