Closed Bug 1252858 Opened 6 years ago Closed 5 years ago

Column picker for the Net panel

Categories

(DevTools :: Netmonitor, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1308451

People

(Reporter: Honza, Unassigned)

References

(Depends on 1 open bug)

Details

The net panel displays growing set of columns and the user should be able to choose which ones should be displayed/hidden.

The UI/UX design for this feature should be elaborated in bug 1170617

Honza
about:config already has a very good-looking table with resizable and sortable columns, and a menu to select displayed columns. It uses XUL tree/treecols/splitters.

Maybe it would be nice to use the same UI style in devtools' tables, too. In addition to netmonitor, there is a similar table in the Memory tool (but that's React/HTML, no XUL...)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1308451
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.