Get software error when adding an attachment

RESOLVED DUPLICATE of bug 1089448

Status

()

Bugzilla
Attachments & Requests
--
major
RESOLVED DUPLICATE of bug 1089448
2 years ago
2 years ago

People

(Reporter: Shahriar Mokhtarzad, Unassigned)

Tracking

5.0.1
x86_64
Unspecified

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

Steps to reproduce:

I have a bug #408. I try to attache a ".PDF" document ~2MB (my limit is set at 10MB).

1- I select the file
2- fill the description filed
3- click on "submit"


Actual results:

I get this message.
Software error:

Insecure dependency in sysopen while running with -T switch at C:/PRG/Perl/lib/File/Temp.pm line 380.

For help, please send mail to the webmaster ...



Expected results:

Successful attachement of the document to bug #408
(Reporter)

Comment 1

2 years ago
more information about my environment

1- OS: Windows Server 2012 R2 Standard
2- Perl version: Active state perl 5, version 20, subversion 3 (v5.20.3) built for MSWin32-x64-multi-thread
3- MySQL: mysql-essential-5.0.15-win32
Severity: normal → major
Priority: -- → P1
Hardware: Unspecified → x86_64
What version of File::Temp?

Paste the output of this command:

perl -M"File::Temp 9999" -e 1
Flags: needinfo?(smokhtar)

Comment 3

2 years ago
Please upgrade to Bugzilla 5.0.2, which has a specific fix for this problem. Reopen if you can still reproduce with 5.0.2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1089448

Updated

2 years ago
Priority: P1 → --
(Reporter)

Comment 4

2 years ago
DYLAN's request
File::Temp version 9999 required--this is only version 0.2304.
BEGIN failed--compilation aborted.
Flags: needinfo?(smokhtar)
(Reporter)

Comment 5

2 years ago
 Frédéric Buclin(In reply to Frédéric Buclin from comment #3)
> Please upgrade to Bugzilla 5.0.2, which has a specific fix for this problem.
> Reopen if you can still reproduce with 5.0.2.
> 
> *** This bug has been marked as a duplicate of bug 1089448 ***
I upgraded ro 5.02 and eth problem persists
(Reporter)

Comment 6

2 years ago
(In reply to Dylan William Hardison [:dylan] from comment #2)
> What version of File::Temp?
> 
> Paste the output of this command:
> 
> perl -M"File::Temp 9999" -e 1

Here is what I get

File::Temp version 9999 required--this is only version 0.2304.

Comment 7

2 years ago
(In reply to Shahriar Mokhtarzad from comment #5)
> I upgraded ro 5.02 and eth problem persists

Look at Bug 1089448 Comment 20, there's one case mentioned which is not yet handled in 5.0.2. So check if TMP or TEMP is available to Bugzilla and if not, make one of it available in your web server.
You need to log in before you can comment on or make changes to this bug.