Closed Bug 1253008 Opened 8 years ago Closed 5 years ago

Service Workers surprisingly unregistered when clearing "browsing and download history"

Categories

(Toolkit :: Data Sanitization, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox47 --- affected

People

(Reporter: callahad, Unassigned)

Details

(Keywords: DevAdvocacy, Whiteboard: [DevRel:P2])

STR:

1. Visit https://www.pokedex.org/
2. Preferences -> Privacy -> Clear Your Recent History
3. Time Range: Everything, What: Only "Browsing & Download History"

What should happen:

- Only my browsing and download history is cleared

What actually happens:

- All service workers are unregistered
- All data cached by the service workers are still present

To verify that cached data persisted, visit https://www.pokedex.org/manifest.json and run the following in the console:

    caches.match('/img/icon-48.png').then(x => console.log(`Resource ${(x && x.ok) ? "WAS" : "WAS NOT"} found in cache:`, x))

This is surprising because "Browsing & Download History" sounds completely unrelated to Service Workers, especially compared to options like "Cache" and "Offline Website Data."
Keywords: privacy
Component: Untriaged → Bookmarks & History
Whiteboard: [DevRel:P2]
Component: Bookmarks & History → General

Could you do me the favor and try to find out if this is still reproducible? (I'd be surprised if it was)

Thanks!

No longer blocks: 1102808
Component: General → Data Sanitization
Flags: needinfo?(dan.callahan)
Priority: -- → P3
Product: Firefox → Toolkit

Resolving

Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(dan.callahan)
You need to log in before you can comment on or make changes to this bug.