firefox thinks linux version of loading.png is corrupt

RESOLVED DUPLICATE of bug 1201766

Status

()

RESOLVED DUPLICATE of bug 1201766
3 years ago
3 years ago

People

(Reporter: gotyaoi, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160215154402

Steps to reproduce:

1. Visit jar:file:///usr/lib64/firefox/browser/omni.ja!/chrome/browser/skin/classic/browser/tabbrowser/loading.png

2. Open inspect console (f12)

3. Reload page

4. Downloaded the firefox sources and visit file:///<path to sources>/browser/themes/linux/tabbrowser/loading.png, file:///<path to sources>/browser/themes/osx/tabbrowser/loading.png and file:///<path to sources>/browser/themes/windows/tabbrowser/loading.png, repeating steps 2 and 3


Actual results:

No image loads for the jar location or for the linux location in the sources. The image loads for the osx and windows locations in the sources.

After opening the inspect console and reloading, an error appears in the console stating "Image corrupt or truncated."


Expected results:

Image of the loading spinner that appears in tabs after the connecting spinner should be displayed in all cases.
(Reporter)

Comment 1

3 years ago
A quick diff over the three images in the sources reveals that the osx and windows versions of loading.png are identical, but the linux version differs. I also ran pngfix and pngcheck on them:
                                                                                         
$ pngfix ./browser/themes/*/tabbrowser/loading.png
IDAT OK  supfast 9 9 706 1040 ./browser/themes/linux/tabbrowser/loading.png
IDAT OK  maximum 11 11 644 1040 ./browser/themes/osx/tabbrowser/loading.png
IDAT OK  maximum 11 11 644 1040 ./browser/themes/windows/tabbrowser/loading.png

$ pngcheck ./browser/themes/*/tabbrowser/loading.png
OK: ./browser/themes/linux/tabbrowser/loading.png (16x16, 32-bit RGB+alpha, non-interlaced, -1258.0%).
OK: ./browser/themes/osx/tabbrowser/loading.png (16x16, 32-bit RGB+alpha, non-interlaced, -1129.0%).
OK: ./browser/themes/windows/tabbrowser/loading.png (16x16, 32-bit RGB+alpha, non-interlaced, -1129.0%)
Component: Untriaged → Theme

Comment 2

3 years ago
You're using a non-official copy of Firefox with system libpng, which is why this is broken.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1201766
(Reporter)

Comment 3

3 years ago
Apologies, I saw that other bug, but as the symptoms it describes are different (Not animating vs not loading at all), I thought a separate report was appropriate.
You need to log in before you can comment on or make changes to this bug.