Closed Bug 1253227 Opened 4 years ago Closed 3 years ago

Bookmark "Help and Tutorials" in Mozilla Firefox folder should open https://support.mozilla.org/en-US/products/firefox instead of https://www.mozilla.org/en-US/firefox/help/ with 404 error

Categories

(Firefox :: Bookmarks & History, defect)

44 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 53
Tracking Status
firefox53 --- verified
firefox54 --- verified

People

(Reporter: jhm.jacobs, Assigned: ayx002, Mentored)

Details

(Keywords: good-first-bug, Whiteboard: [good first bug][lang=js])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

Steps to reproduce:

I clicked Help in the Moilla Firefox bookmarks folder


Actual results:

I was taken to a Mozilla page that told me I had been misdirected. Fault announcement 404 was shown, "page not found", but it was a Mozilla page.


Expected results:

Simply, I should have been helped
Yes, the bookmark should open the localized page https://support.mozilla.org/en-US/products/firefox instead of https://www.mozilla.org/en-US/firefox/help/
Status: UNCONFIRMED → NEW
Component: Untriaged → Bookmarks & History
Ever confirmed: true
Summary: Choosing the bookmark link Help in Mozilla bookmarks (https://www.mozilla.org/nl/firefox/help/) I am directed to a page that says Oops, you lost the right direction (or something like it, it was in Dutch) → Bookmark "Help and Tutorials" in Mozilla Firefox folder should open https://support.mozilla.org/en-US/products/firefox instead of https://www.mozilla.org/en-US/firefox/help/ with 404 error
Is this bug still unresolved?
I do not know, I do not understand the original problem, what is Help in the bookmarksfolder? It is too long ago. Consider it resolved.
Seems to be WFM.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Let' use the bug to fix bookmarks.html.in then. Sounds easy enough for a first good bug.
Mentor: mak77
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Whiteboard: [good first bug][lang=js]
Keywords: good-first-bug
I would love to be assigned to this! So after reading the above comments I see that:
  1. https://www.mozilla.org/nl-nl/firefox/help/
  2. https://www.mozilla.org/nl-be/firefox/help/
  3. https://www.mozilla.org/nl/firefox/help/ 
All correctly redirect to https://support.mozilla.org/nl/products/firefox.

But, bookmarks.html.in is redirecting to the incorrect URL.

So I should have that also redirect to https://support.mozilla.org/nl/products/firefox.
(In reply to ayx002 from comment #8)
> I would love to be assigned to this! So after reading the above comments I
> see that:
>   1. https://www.mozilla.org/nl-nl/firefox/help/
>   2. https://www.mozilla.org/nl-be/firefox/help/
>   3. https://www.mozilla.org/nl/firefox/help/ 
> All correctly redirect to https://support.mozilla.org/nl/products/firefox.
> 
> But, bookmarks.html.in is redirecting to the incorrect URL.
> 
> So I should have that also redirect to
> https://support.mozilla.org/nl/products/firefox.

I would like the add I have the FireFox for Desktop code base and able to build!
(In reply to Alan from comment #10)
> Created attachment 8824616 [details] [diff] [review]
> No need to redirect.

Hey Alan, thanks for looking at this. Are you using mercurial/hg or git, and if so can you put this on mozreview or put up a patch on this bug? See https://mozilla-version-control-tools.readthedocs.io/en/latest/hgmozilla/firefoxworkflow.html and https://mozilla-version-control-tools.readthedocs.io/en/latest/mozreview.html for some documentation. Do feel free to ask more questions if things are unclear. :-)
Assignee: nobody → ayx002
Mentor: gijskruitbosch+bugs
Status: REOPENED → ASSIGNED
(In reply to :Gijs from comment #11)
> (In reply to Alan from comment #10)
> > Created attachment 8824616 [details] [diff] [review]
> > No need to redirect.
> 
> Hey Alan, thanks for looking at this. Are you using mercurial/hg or git, and
> if so can you put this on mozreview or put up a patch on this bug? See
> https://mozilla-version-control-tools.readthedocs.io/en/latest/hgmozilla/
> firefoxworkflow.html and
> https://mozilla-version-control-tools.readthedocs.io/en/latest/mozreview.
> html for some documentation. Do feel free to ask more questions if things
> are unclear. :-)

So I have Mercurial setup. I am able to create a commit, however, I am not able to push to Mozreview. When I try to push I recieve a "remote: Permission denied (publickey)." Does this mean my setup in the hg config file is incorrect? I used the setup wizard too.
Attachment #8824839 - Flags: review?(gijskruitbosch+bugs)
(In reply to Alan from comment #12)
> (In reply to :Gijs from comment #11)
> > (In reply to Alan from comment #10)
> > > Created attachment 8824616 [details] [diff] [review]
> > > No need to redirect.
> > 
> > Hey Alan, thanks for looking at this. Are you using mercurial/hg or git, and
> > if so can you put this on mozreview or put up a patch on this bug? See
> > https://mozilla-version-control-tools.readthedocs.io/en/latest/hgmozilla/
> > firefoxworkflow.html and
> > https://mozilla-version-control-tools.readthedocs.io/en/latest/mozreview.
> > html for some documentation. Do feel free to ask more questions if things
> > are unclear. :-)
> 
> So I have Mercurial setup. I am able to create a commit, however, I am not
> able to push to Mozreview. When I try to push I recieve a "remote:
> Permission denied (publickey)." Does this mean my setup in the hg config
> file is incorrect? I used the setup wizard too.

Woo! Was able to create the review! So I had my [path] for SSH and not HTTPS!
Attachment #8824839 - Flags: review?(gijskruitbosch+bugs) → review?(mak77)
Attachment #8824839 - Flags: review?(gijskruitbosch+bugs)
Attachment #8824839 - Flags: review?(mak77)
Comment on attachment 8824839 [details]
Fix to Bug 1253227 changing bookmarks.html.in#36 from old URL to /products/firefox

https://reviewboard.mozilla.org/r/103120/#review103772

Very nice, thanks!
Attachment #8824839 - Flags: review?(gijskruitbosch+bugs) → review+
I've pushed this to our tryserver to see if tests are happy with this - apparently changes to this file have a history of accidentally breaking tests that contain assumptions about these bookmarks...

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ef15dd85e27a46700822f37acf69fe67f56a8dab
This looks like tests are fine, so I've landed it for you via autoland. Thanks again for the patch. Let me know if you want a pointer to some other bugs that might provide a follow-up challenge! :-)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/81a4f1a55040
Fix to Bug 1253227 changing bookmarks.html.in#36 from old URL to /products/firefox r=Gijs
(In reply to :Gijs from comment #17)
> This looks like tests are fine, so I've landed it for you via autoland.
> Thanks again for the patch. Let me know if you want a pointer to some other
> bugs that might provide a follow-up challenge! :-)

I would love a pointer to more bugs! Thank you so much, it's a great feeling finishing my first patch!
https://hg.mozilla.org/mozilla-central/rev/81a4f1a55040
Status: ASSIGNED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
(In reply to Alan from comment #19)
> (In reply to :Gijs from comment #17)
> > This looks like tests are fine, so I've landed it for you via autoland.
> > Thanks again for the patch. Let me know if you want a pointer to some other
> > bugs that might provide a follow-up challenge! :-)
> 
> I would love a pointer to more bugs! Thank you so much, it's a great feeling
> finishing my first patch!

Great! I realized I'm not sure what programming languages you're comfortable with. For some small JS stuff, see e.g. bug 1312216. For some CSS work (assuming you have access to Windows 7 or Windows 8), see e.g. bug 1111138. Feel free to needinfo me and/or the mentor of the bug (where it isn't me) if you need more details to get going on those, or if neither of those work and you'd like me to find you something else. :-)
(In reply to :Gijs from comment #21)
> (In reply to Alan from comment #19)
> > (In reply to :Gijs from comment #17)
> > > This looks like tests are fine, so I've landed it for you via autoland.
> > > Thanks again for the patch. Let me know if you want a pointer to some other
> > > bugs that might provide a follow-up challenge! :-)
> > 
> > I would love a pointer to more bugs! Thank you so much, it's a great feeling
> > finishing my first patch!
> 
> Great! I realized I'm not sure what programming languages you're comfortable
> with. For some small JS stuff, see e.g. bug 1312216. For some CSS work
> (assuming you have access to Windows 7 or Windows 8), see e.g. bug 1111138.
> Feel free to needinfo me and/or the mentor of the bug (where it isn't me) if
> you need more details to get going on those, or if neither of those work and
> you'd like me to find you something else. :-)

Thank you! I got another r+ for a bug on SeaMonkey! But I definitely want to try a bug using Python.
(In reply to Alan from comment #22)
> Thank you! I got another r+ for a bug on SeaMonkey! But I definitely want to
> try a bug using Python.

Oh, right. I don't work on much that touches python, but you could try looking at:

https://www.joshmatthews.net/bugsahoy/?py=1&unowned=1

which should have a number of mentored bugs that involve python and are currently unowned. :-)
[Bugday-20170125]
Operating System : Windows 10
Browser:
[Bugday-20170125]
Operating System : Windows 10
Browser: Firefox Nighly

    I verified the bug. While clicking on bookmark folder, I got help from the Firefox help. Thus the bug is fixed.
Thank you
Status: RESOLVED → VERIFIED
QA Whiteboard: [good first verify]
[Bugday-20170329]
Operating System:Windows 10(64-bit)
Browser: Firefox Beta 53.0b8
You need to log in before you can comment on or make changes to this bug.