mozilla 0.9.8-1.ximian.2 will not start due to a missing so file

VERIFIED INVALID

Status

--
blocker
VERIFIED INVALID
17 years ago
14 years ago

People

(Reporter: spin, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
**************************************************
nsNativeComponentLoader: GetFactory(/usr/lib/mozilla/components/libtimer_gtk.so)
Load FAILED with error: /usr/lib/mozilla/components/libtimer_gtk.so: cannot open
shared object file: No such file or directory
**************************************************
Segmentation fault (core dumped)

Comment 1

17 years ago
That is a problem with the Ximian packages missing a file.

It is already reported in Ximian's bugzilla, see their bug
http://bugzilla.ximian.com/show_bug.cgi?id=20299

Not a Mozilla issue - resolving as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 2

17 years ago
for reference libtimer_gtk is no longer used by mozilla, you should probably delete component.reg and any references to it from components/

vrfy invalid
Status: RESOLVED → VERIFIED

Comment 3

17 years ago
Reporter: Just to test something: Can you delete component.reg in the mozilla
binary directory, and then try starting it again as root this time. 
(IF starting as root works: Also start each component once, then quit and start
as regular user.) Please report back on web whether this worked or not.
(Reporter)

Comment 4

17 years ago
I deleted component.reg and ran a script to regenerate that file.
/usr/lib/mozilla/rebuild-databases.sh as root.

Worked fine, after which galeon also worked fine.

Aran

Comment 5

17 years ago
*** Bug 125433 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.