Closed Bug 1253261 Opened 4 years ago Closed 3 years ago

64-bit Flash 19 microphone cannot record audio in Windows 10 sandbox

Categories

(External Software Affecting Firefox :: Flash (Adobe), defect, P2)

x86_64
Windows 10
defect

Tracking

(firefox50 wontfix, firefox51 wontfix, firefox52 affected, firefox53 affected)

RESOLVED FIXED
Tracking Status
firefox50 --- wontfix
firefox51 --- wontfix
firefox52 --- affected
firefox53 --- affected

People

(Reporter: bobowen, Unassigned)

References

Details

(Keywords: flashplayer, Whiteboard: sbwn1)

+++ This bug was initially created as a clone of Bug #1206278 +++

Same issue but with 64-bit Firefox and Flash Player.

Looks like fix will require changes to Firefox and Flash Player.
Whiteboard: [sb?]
Depends on: 1251202
Whiteboard: [sb?] → sbwn1
I'm closing a lot of bugs which are filed as Adobe Flash bugs which are either irrelevant, not actionable, or not serious enough to track in the Mozilla bug tracker. For the most part, Flash bugs should be filed in Adobe bugbase, and we'll only track a few highly-critical issues in the Mozilla tracker.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INCOMPLETE
Bob do you know what the status of this is?
Status: RESOLVED → REOPENED
Flags: needinfo?(bobowen.code)
Resolution: INCOMPLETE → ---
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #2)
> Bob do you know what the status of this is?

This is waiting on bug 1251202, once we have that out on release Adobe can fix up their microphone use. This is considered lower priority than level 1 content sandboxing on Windows currently.
Flags: needinfo?(bobowen.code)
This Flash sandbox bug should probably block wider testing of 64-bit Firefox because they break existing Flash content.
Priority: -- → P2
We are currently waiting for Adobe engineers to change Flash to call our new plugin audio notification API (bug 1251202).

We would like to fix this 64-bit Flash bug in Firefox 52 because we plan to run a Funnelcake experiment comparing 32- and 64-bit Firefox users in the Firefox 52 release.
adobe has confirmed this is fixed on their end, they'll release when they are ready.
Status: REOPENED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.