TC Linux 64 PGO Tests on Tier-2

RESOLVED FIXED in mozilla49

Status

Firefox Build System
Task Configuration
RESOLVED FIXED
2 years ago
5 months ago

People

(Reporter: selenamarie, Assigned: gbrown)

Tracking

(Blocks: 1 bug)

unspecified
mozilla49
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

This is a planning bug for tracking work related to getting Linux 64 Opt and PGO Tests on Tier-2.
we should consider splitting this out as opt and pgo, something to tackle as we have linux64 opt builds already running as tier2 in production and tests could be a quick thing to bring up.
See https://bugzilla.mozilla.org/show_bug.cgi?id=1251893#c18 -- make sure we use ondemand symbol downloads for opt.
See Also: → bug 1251893
Depends on: 1267825
Summary: TC Linux 64 Opt and PGO Tests on Tier-2 → TC Linux 64 PGO Tests on Tier-2
Assignee: nobody → gbrown
:gbrown - Ok to close this bug?
Flags: needinfo?(gbrown)
No - still work to do here. (I think there was confusion with opt.)
Flags: needinfo?(gbrown)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1253298
Blocks: 1253298
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Created attachment 8754099 [details] [diff] [review]
add linux64 pgo test tasks

This adds all the unit test task definitions for linux-64 pgo.

There were some complications for VideoPuppeteer ("external media tests"): The linux-64 opt definition was missing, the linux-64 debug was using the wrong --download-symbols option, and the treeherder symbols were missing the customary "tc-". Otherwise, this is just adding all the tests using the same test options as for opt, but against a pgo build.

All tests run as tier 2, side-by-side with buildbot-triggered pgo, for now.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=2261081acd10
Attachment #8754099 - Flags: review?(dustin)
Attachment #8754099 - Flags: review?(dustin) → review+

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f4968de8f706
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49

Updated

5 months ago
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.