All users were logged out of Bugzilla on October 13th, 2018

Disable rust on win32

RESOLVED FIXED in Firefox 47

Status

RESOLVED FIXED
3 years ago
8 months ago

People

(Reporter: rillian, Assigned: rillian)

Tracking

Trunk
mozilla47

Firefox Tracking Flags

(firefox47 fixed)

Details

Attachments

(1 attachment)

Temporarily remove --enable-rust from win32 mozconfigs until we can address bug 1253202.
(Assignee)

Comment 1

3 years ago
Created attachment 8726471 [details] [diff] [review]
Disable rust on win32

I'm not going to get a custom library build ready for testing in time for the next nightly, so work around the top-crash in the meantime by disabling the code.

This leaves rust enabled for debug builds for testing convenience.
Attachment #8726471 - Flags: review?(mshal)
Given that bug 1253202 was probably caused by the same thing bug 1252041 was caused by (using SSE2 instructions), then it's probably worth pointing out that the standard library has SSE2 enabled by default on all platforms I believe (e.g. including Linux/OSX). It looks like the only crash reports came from Windows, though? If any Linux/OSX user uses one of those old CPUs though they're likely to see the same crash.

Just FYI!
Comment on attachment 8726471 [details] [diff] [review]
Disable rust on win32

Looks fine. We can always disable it in other platforms if they exhibit the crash as well. It wasn't seen it all in win64?
Attachment #8726471 - Flags: review?(mshal) → review+
I believe x86_64 by definition has SSE2, it's just x86 that may or may not have SSE2. (I may be remembering wrong though)
OS X for x86 requires at least Core 2, so SSE2 is never an issue. I heard we have enabled SSE2 for Linux 32bit since long ago?

Comment 7

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/530047c97d83
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox47: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.