There is an extra text box in the link properties box; edit fields won't accept caret

VERIFIED FIXED in mozilla0.9.9

Status

SeaMonkey
Composer
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: michael wendell, Assigned: Charles Manske)

Tracking

Trunk
mozilla0.9.9
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

17 years ago
If you try to edit a link in composer, you will notice that there is an extra
text box, and if you try to edit the box, and save the changes, nothing happens.

Steps to Reproduce:
1. Launch Composer
2. Click on the link icon on the toolbar
3. Enter text for the link text and link location, and click on OK
4. Double click on the link to bring the link properties dialog back up

Actual Results:
There is an extra text box under the link text, and if you type something in
there and click on OK, no change is made to the page.

Expected Results:
I would expect that this box is not there, or if it is there, that making
changes to it would somehow change the page.

Note:  This started on trunk build 02-09, and is still happening on the 02-13
trunk build.

Comment 1

17 years ago
-->cmanske
Assignee: syd → cmanske
Keywords: nsbeta1+, regression
Whiteboard: EDITORBASE
Target Milestone: --- → mozilla0.9.9
(Assignee)

Comment 2

17 years ago
I can't reproduce this!
(Assignee)

Comment 3

17 years ago
Ok, I see it now. I had a fix for another bug that was hiding this!
Status: NEW → ASSIGNED
(Assignee)

Comment 4

17 years ago
Created attachment 69582 [details] [diff] [review]
Fix
(Assignee)

Updated

17 years ago
Keywords: patch, review
Whiteboard: EDITORBASE → EDITORBASE+, FIX IN HAND, need r=,sr=
(Assignee)

Comment 5

17 years ago
The fix for this is identical to that for bug 103197. Not exactly a dup; more of 
a "side effect".

Comment 6

17 years ago
Comment on attachment 69582 [details] [diff] [review]
Fix

why doesn't this use 0 instead of 1?
Attachment #69582 - Flags: needs-work+

Comment 7

17 years ago
cc danm/brendan for reviews (when a new patch is developed)
Summary: There is an extra text box in the link properties box → There is an extra text box in the link properties box; edit fields won't accept caret
(Assignee)

Comment 8

17 years ago
Right, "0" seems to work fine. I'll use that
(Assignee)

Comment 9

17 years ago
Created attachment 69666 [details] [diff] [review]
Better fix -- need to keep "textbox" in scope

Thanks to Neil for this fix
Attachment #69582 - Attachment is obsolete: true
(Assignee)

Comment 10

17 years ago
Comment on attachment 69666 [details] [diff] [review]
Better fix -- need to keep "textbox" in scope

r=cmanske
Fix is by neil@parkwaycc.co.uk
Attachment #69666 - Flags: review+

Comment 11

17 years ago
kin prefers setTimeout( function(textbox) { textbox.focus(); }, 0, textbox );
(Assignee)

Comment 12

17 years ago
Created attachment 69670 [details] [diff] [review]
One more try!

This "more explicitly passes in the textbox" to the inner function
Attachment #69666 - Attachment is obsolete: true
(Assignee)

Comment 13

17 years ago
Comment on attachment 69670 [details] [diff] [review]
One more try!

r=cmanske
again, fix by Neil
Attachment #69670 - Flags: review+

Comment 14

17 years ago
Comment on attachment 69670 [details] [diff] [review]
One more try!

sr=kin@netscape.com
Attachment #69670 - Flags: superreview+
(Assignee)

Comment 15

17 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Keywords: patch, regression, review
Resolution: --- → FIXED
Whiteboard: EDITORBASE+, FIX IN HAND, need r=,sr=
(Reporter)

Comment 16

17 years ago
Verified on 2002021803.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.