Closed Bug 1253561 Opened 5 years ago Closed 5 years ago

Stopping the profiler freezes the browser in marker-view.js:109

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

defect
Not set
normal

Tracking

(firefox47 affected)

RESOLVED DUPLICATE of bug 1152441
Tracking Status
firefox47 --- affected

People

(Reporter: past, Unassigned)

Details

I've reproduced this with Firefox 44, 46 & 48 on a page that uses a worker script, which might be related. Patrick reproduced it, too. STR:

1. Visit http://astithas.com/speller/
2. Open the profiler and start a recording
3. Click the "train" button in the page
4. Stop the recording after a while
5. Browser hangs (release, non-e10s), toolbox hangs (nightly, e10s) or the slow script dialog pops up (dev-edition) pointing at marker-view.js:109
Permanently hangs or is it just really slow and eventually completes?
It seems to be hanging permanently in release (more than 15 minutes and the Dock icon only shows the Force Quit option). In nightly I see the content process hang and show the spinner after a while.
If it hangs on that line of the waterfall, I'm guessing it's related to the other issues of rendering large amounts of markers (bug 1152441), since we don't handle that lazily (bug 1185181). Thinkin' this could be a dupe of bug 1152441 most likely
Duping as bug 1152441
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1152441
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.