Arrow of image preview in devtool network panel does not change position according to orientation of preview box

RESOLVED DUPLICATE of bug 932317

Status

()

Firefox
Developer Tools: Netmonitor
RESOLVED DUPLICATE of bug 932317
2 years ago
a year ago

People

(Reporter: Jens, Unassigned)

Tracking

({regression})

44 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox44 wontfix, firefox45 wontfix, firefox46- wontfix, firefox47- wontfix)

Details

Attachments

(6 attachments)

(Reporter)

Description

2 years ago
Created attachment 8726671 [details]
2016-03-04 12_48_52-Kadence Themes _ Free and Premium Wordpress Themes - Firefox Developer Edition.png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

Steps to reproduce:

1. Open devtools -> network panel
2. Click "Dock to side of browser window" so that the space to top and right becomes narrow
3. Hover over an image in the networ panel




Actual results:

The image preview opens with a different orientation (good!) but the arrow of the preview box does not point to the right image any more (bad). See screenshots.


Expected results:

The image should not stick to the "bottom left" all the time. Depending on the orientation of the preview box the arraw should be placed at "top left", "top right" or "bottom right" sometimes.
(Reporter)

Updated

2 years ago
Component: Untriaged → Developer Tools: Netmonitor
(Reporter)

Comment 1

2 years ago
Created attachment 8726673 [details]
Screenshot2
(Reporter)

Comment 2

2 years ago
Created attachment 8726674 [details]
Screenshot3
(Reporter)

Comment 3

2 years ago
Created attachment 8726678 [details]
Also happens when hovering <img src="xxx"> in Inspector

Not only network monitor: The arrow is also misplaced when hovering <img src="xxx"> in Inspector
(Reporter)

Comment 4

2 years ago
Created attachment 8726699 [details]
Interestingly, the arrow is placed correct for the events popup (see screenshot)

Interestingly, the arrow is placed correct for the events popup (see screenshot)

Comment 5

2 years ago
Created attachment 8726706 [details]
index.html

Comment 6

2 years ago
The issue depends on the dimensions of the picture, with large picture, the tooltip with the preview is offset.

Regression range:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=d08afef8b42d1f481dc5f9cca8df35ed0a848836&tochange=396725444e10c322b95becb2619e6837c9308b09

Albert Juhé Lluveras — Bug 951714 - DevTools Themes: Update network panel table headers to match new theme. r=vporof
Blocks: 951714
status-firefox44: --- → affected
status-firefox45: --- → affected
status-firefox46: --- → affected
status-firefox47: --- → affected
tracking-firefox46: --- → ?
Flags: needinfo?(albertjuhe)
Keywords: regression
Version: 47 Branch → 44 Branch

Comment 7

2 years ago
[Tracking Requested - why for this release]:
tracking-firefox47: --- → ?
Not sure we need to track this minor regression from 44, though we should fix it. 

Brian, maybe you could have a look once you're back, since you reviewed the patch originally and may be familiar with the code. Or if you can help find an owner for the bug that would also be great!
tracking-firefox46: ? → -
tracking-firefox47: ? → -
Flags: needinfo?(bgrinstead)
This is a duplicate of bug 932317, not sure which one we want to close though. There's been already quite a lot of investigation in bug 932317.
(In reply to Patrick Brosset [:pbrosset] [:pbro] from comment #9)
> This is a duplicate of bug 932317, not sure which one we want to close
> though. There's been already quite a lot of investigation in bug 932317.

What about the regression range in Comment 6?  Could that be a coincidence / maybe some dimensions in the net monitor changed that triggered the same issue as in 932317?  If so, I'd be in favor of closing this one since Bug 932317 has a lot of discussion.
Flags: needinfo?(pbrosset)
So I don't think this is a regression. The changeset mentioned in comment 6 landed in FF45, so I tried to reproduce the issue in FF42 for good measure, and I managed to reproduce it.
Also, I'm the one who landed the tooltip feature in the first place (in FF27 I think), and this problem has always been known, there's been various bugs filed about it way earlier than FF45.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(pbrosset)
Resolution: --- → DUPLICATE
Duplicate of bug: 932317

Updated

2 years ago
Flags: needinfo?(albertjuhe)
Flags: needinfo?(bgrinstead)
status-firefox44: affected → wontfix
status-firefox45: affected → wontfix
status-firefox46: affected → wontfix
status-firefox47: affected → wontfix
You need to log in before you can comment on or make changes to this bug.