Ugly transparency for "plain" popups and arrows in ffdevtools (dark theme)

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools: Inspector
P3
normal
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: Jens, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [btpp-backlog])

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8726698 [details]
Arrows with transparency in dark theme

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

Steps to reproduce:

1. Open devtools and inspektor
2. Click on any "ev" node to get the events popup (see screenshot)


Actual results:

The letters from the below html shines through the transparent arrow. See screenshot


Expected results:

Should be more like in the light theme where the text does not shine trough in such a way. Seems like the transparency for dark theme is set higher than in the light theme.
(Reporter)

Updated

2 years ago
Component: Untriaged → Developer Tools: Inspector

Comment 1

2 years ago
It's because the arrow as the same transparency as the background tooltip.
(Reporter)

Comment 2

2 years ago
Created attachment 8726721 [details]
Too_high_transparency_dark_theme.png

Besides of this or maybe due to this: Transparency of the background popup seems to be too high in the dark theme anyway.
(Reporter)

Comment 3

2 years ago
Created attachment 8726729 [details]
Object_with_attributes.png

If the looked at object in the popup has attributes (Array/Object not just plain String) then the transparency is way lower and it looks much better. See Screenshot
(Reporter)

Updated

2 years ago
Summary: Ugly transparency for arrow of popups in ffdevtools (dark theme) → Ugly transparency for "plain" popups and arrows in ffdevtools (dark theme)
I think the opacity is the same in both themes, but it shows a bit more with the dark-theme indeed.
Helen, do you mind taking a look at this and advising if we need to adjust the opacity of our tooltips?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(hholmes)
Priority: -- → P3
Whiteboard: [btpp-backlog]
I'm marking this as WONTFIX because of Bug 1258365.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(hholmes)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.