jar should fill in necko's buffer

VERIFIED DUPLICATE of bug 189528

Status

()

Core
Networking: JAR
P2
normal
VERIFIED DUPLICATE of bug 189528
17 years ago
10 years ago

People

(Reporter: Suresh Duddi (gone), Assigned: Suresh Duddi (gone))

Tracking

({perf})

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
jar protocol seems to read in the entire file and then copy parts of it into
necko's buffer. Rather it would be better if it uncompresses into necko's buffer
directly. This would save

- the extra copy
- the malloc/free cost
- the fragmentation associated with allocations
(Assignee)

Comment 1

17 years ago
Per dveditz: "care should be taken so we dont dont seek too much for every time
we fill necko's buffer"
(Assignee)

Updated

17 years ago
Keywords: footprint, nsbeta1, perf
Priority: -- → P2
Target Milestone: --- → mozilla1.0
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

16 years ago
This is a perf win. Not footprint. Will prevent 200+ allocation of big buffers
and will save on extra memcpy.
Keywords: footprint, nsbeta1 → nsbeta1+

Updated

15 years ago
Target Milestone: mozilla1.0 → ---

Comment 3

15 years ago
This is fixed in bug 189528, so can be closed now.

*** This bug has been marked as a duplicate of 189528 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
yup.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Miscellany → General
QA Contact: brendan → general

Updated

10 years ago
Component: General → Networking: JAR
QA Contact: general → networking.jar
You need to log in before you can comment on or make changes to this bug.