Intermittent Windows e10s dom/push/test/test_data.html | This test left crash dumps behind, but we weren't expecting it to! | application crashed [None]

RESOLVED DUPLICATE of bug 1242221

Status

()

RESOLVED DUPLICATE of bug 1242221
3 years ago
3 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Unspecified
Windows 7
Points:
---

Firefox Tracking Flags

(e10s+, firefox47 affected)

Details

(Reporter)

Description

3 years ago
Would be useful to know what's going on with the minidumps here. Both instances died at the same point of the test AFAICT, so that may be interesting.

https://treeherder.mozilla.org/logviewer.html#?job_id=17674752&repo=try

10:42:29     INFO -  0 INFO SimpleTest START
10:42:29     INFO -  1 INFO TEST-START | dom/push/test/test_data.html
10:42:29     INFO -  [Child 2904] WARNING: TabChild::SetFocus not supported in TabChild: file c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/dom/ipc/TabChild.cpp, line 1020
10:42:29     INFO -  ++DOMWINDOW == 6 (0E2B3C00) [pid = 2904] [serial = 6] [outer = 0E2B9800]
10:42:29     INFO -  --DOCSHELL 1B8CFC00 == 4 [pid = 4080] [id = 6]
10:42:30     INFO -  ++DOMWINDOW == 7 (0E6A3000) [pid = 2904] [serial = 7] [outer = 0E2B9800]
10:42:30     INFO -  ++DOCSHELL 1199F000 == 5 [pid = 4080] [id = 7]
10:42:30     INFO -  ++DOMWINDOW == 15 (1199F400) [pid = 4080] [serial = 15] [outer = 00000000]
10:42:30     INFO -  ++DOMWINDOW == 16 (11997000) [pid = 4080] [serial = 16] [outer = 1199F400]
10:42:30     INFO -  ++DOMWINDOW == 17 (11996C00) [pid = 4080] [serial = 17] [outer = 1199F400]
10:42:30     INFO -  ++DOCSHELL 11457000 == 6 [pid = 4080] [id = 8]
10:42:30     INFO -  ++DOMWINDOW == 18 (119C5000) [pid = 4080] [serial = 18] [outer = 00000000]
10:42:30     INFO -  ++DOMWINDOW == 19 (119CFC00) [pid = 4080] [serial = 19] [outer = 119C5000]
10:42:31     INFO -  ++DOCSHELL 0E61D800 == 3 [pid = 2904] [id = 3]
10:42:31     INFO -  ++DOMWINDOW == 8 (0E622400) [pid = 2904] [serial = 8] [outer = 00000000]
10:42:31     INFO -  ++DOMWINDOW == 9 (0E623800) [pid = 2904] [serial = 9] [outer = 0E622400]
10:42:31     INFO -  [2512] WARNING: NSS will be initialized without a profile directory. Some things may not work as expected.: file c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/security/manager/ssl/nsNSSComponent.cpp, line 940
10:42:31     INFO -  [2512] WARNING: site security information will not be persisted: file c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/security/manager/ssl/nsSiteSecurityService.cpp, line 260
10:42:31     INFO -  [2512] WARNING: NS_ENSURE_SUCCESS(rv, NS_ERROR_UNEXPECTED) failed with result 0x80004005: file c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/extensions/cookie/nsPermissionManager.cpp, line 822
10:42:32     INFO -  JavaScript error: resource://gre/modules/Webapps.jsm, line 20: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
10:42:32     INFO -  [2512] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/netwerk/base/nsChannelClassifier.cpp, line 323
10:42:32     INFO -  JavaScript error: resource://gre/modules/Webapps.jsm, line 20: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
10:42:32     INFO -  [2512] WARNING: Forcing memory-only entry since CacheFileIOManager doesn't have mCacheDirectory.: file c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/netwerk/cache2/CacheFile.cpp, line 519
10:42:32     INFO -  JavaScript error: resource://gre/modules/Webapps.jsm, line 20: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
10:42:32     INFO -  [2512] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/netwerk/base/nsChannelClassifier.cpp, line 323
10:42:32     INFO -  JavaScript error: resource://gre/modules/Webapps.jsm, line 20: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
10:42:32     INFO -  [2512] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/netwerk/base/nsChannelClassifier.cpp, line 323
10:42:32     INFO -  JavaScript error: resource://gre/modules/Webapps.jsm, line 20: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
10:42:32     INFO -  [2512] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/netwerk/base/nsChannelClassifier.cpp, line 323
10:42:33     INFO -  JavaScript error: resource://gre/modules/Webapps.jsm, line 20: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
10:42:33     INFO -  [2512] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/netwerk/base/nsChannelClassifier.cpp, line 323
10:42:33     INFO -  JavaScript error: resource://gre/modules/Webapps.jsm, line 20: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
10:42:33     INFO -  [2512] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/netwerk/base/nsChannelClassifier.cpp, line 323
10:42:33     INFO -  [Parent 4080] WARNING: pipe error: 109: file c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 333
10:42:33     INFO -  [Child 2904] WARNING: A control runnable was posted to a worker that is already shutting down!: file c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/dom/workers/WorkerPrivate.cpp, line 2389
10:42:33     INFO -  [Child 2904] WARNING: Failed to update worker preferences!: file c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/dom/workers/WorkerPrivate.cpp, line 2970
10:42:33     INFO -  MEMORY STAT | vsize 367MB | vsizeMaxContiguous 685MB | residentFast 97MB | heapAllocated 15MB
10:42:33     INFO -  2 INFO TEST-PASS | dom/push/test/test_data.html | Wrong endpoint
10:42:33     INFO -  3 INFO TEST-PASS | dom/push/test/test_data.html | Mismatched Base64-encoded key: p256dh
10:42:33     INFO -  4 INFO TEST-PASS | dom/push/test/test_data.html | Mismatched Base64-encoded key: auth
10:42:33     INFO -  5 INFO TEST-PASS | dom/push/test/test_data.html | Missing key share
10:42:33     INFO -  6 INFO TEST-PASS | dom/push/test/test_data.html | Mismatched key share
10:42:33     INFO -  7 INFO TEST-PASS | dom/push/test/test_data.html | Missing auth secret
10:42:33     INFO -  8 INFO TEST-PASS | dom/push/test/test_data.html | Mismatched auth secret
10:42:33     INFO -  9 INFO TEST-PASS | dom/push/test/test_data.html | Wrong text message data
10:42:33     INFO -  10 INFO TEST-PASS | dom/push/test/test_data.html | Wrong array buffer message data
10:42:33     INFO -  11 INFO TEST-PASS | dom/push/test/test_data.html | Unexpected error parsing JSON
10:42:33     INFO -  12 INFO TEST-PASS | dom/push/test/test_data.html | Wrong JSON message data
10:42:33     INFO -  13 INFO TEST-PASS | dom/push/test/test_data.html | Should include data for empty messages
10:42:33     INFO -  14 INFO TEST-PASS | dom/push/test/test_data.html | Wrong text for empty message
10:42:33     INFO -  15 INFO TEST-PASS | dom/push/test/test_data.html | Wrong buffer length for empty message
10:42:33     INFO -  16 INFO TEST-PASS | dom/push/test/test_data.html | Expected JSON parse error for empty message
10:42:33     INFO -  17 INFO TEST-PASS | dom/push/test/test_data.html | Wrong text for message with emoji
10:42:33     INFO -  18 INFO TEST-PASS | dom/push/test/test_data.html | Wrong blob data for message with emoji
10:42:33     INFO -  19 INFO TEST-PASS | dom/push/test/test_data.html | Should exclude data for blank messages
10:42:33     INFO -  20 INFO TEST-UNEXPECTED-ERROR | dom/push/test/test_data.html | This test left crash dumps behind, but we weren't expecting it to!
10:42:33     INFO -  {u'unexpected_crashdump_files': [u'c:\\users\\cltbld\\appdata\\local\\temp\\tmpktwkmz.mozrunner\\minidumps\\3e65ba55-b438-4787-bd2f-c3b1263a90f0.dmp']}
10:42:33     INFO -  TEST-INFO took 4258ms
10:42:33     INFO -  21 INFO TEST-OK | dom/push/test/test_data.html
10:42:33     INFO -  TEST-INFO | started process screenshot
10:42:33     INFO -  TEST-INFO | screenshot: exit 0
10:42:33     INFO -  22 INFO TEST-UNEXPECTED-FAIL | dom/push/test/test_data.html | undefined assertion name - Result logged after SimpleTest.finish()

10:43:02     INFO -  mozcrash Copy/paste: C:\slave\test\build\win32-minidump_stackwalk.exe c:\users\cltbld\appdata\local\temp\tmpktwkmz.mozrunner\minidumps\3e65ba55-b438-4787-bd2f-c3b1263a90f0.dmp C:\slave\test\build\symbols
10:43:02     INFO -  mozcrash Saved minidump as C:\slave\test\build\blobber_upload_dir\3e65ba55-b438-4787-bd2f-c3b1263a90f0.dmp
10:43:02  WARNING -  PROCESS-CRASH | Main app process exited normally | application crashed [None]
10:43:02     INFO -  Crash dump filename: c:\users\cltbld\appdata\local\temp\tmpktwkmz.mozrunner\minidumps\3e65ba55-b438-4787-bd2f-c3b1263a90f0.dmp
10:43:02     INFO -  stderr from minidump_stackwalk:
10:43:02     INFO -  2016-03-05 10:43:02: minidump.cc:4197: INFO: Minidump opened minidump c:\users\cltbld\appdata\local\temp\tmpktwkmz.mozrunner\minidumps\3e65ba55-b438-4787-bd2f-c3b1263a90f0.dmp
10:43:02     INFO -  2016-03-05 10:43:02: minidump.cc:4617: ERROR: ReadBytes: read 0/32
10:43:02     INFO -  2016-03-05 10:43:02: minidump.cc:4288: ERROR: Minidump cannot read header
10:43:02     INFO -  2016-03-05 10:43:02: stackwalk.cc:125: ERROR: Minidump c:\users\cltbld\appdata\local\temp\tmpktwkmz.mozrunner\minidumps\3e65ba55-b438-4787-bd2f-c3b1263a90f0.dmp could not be read
10:43:02     INFO -  2016-03-05 10:43:02: minidump.cc:4169: INFO: Minidump closing minidump
(Reporter)

Updated

3 years ago
See Also: → bug 1242221
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 2
* fx-team: 2
* mozilla-inbound: 1

Platform breakdown:
* windows7-32: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1253852&startday=2016-02-29&endday=2016-03-06&tree=all

Updated

3 years ago
Blocks: 984139
tracking-e10s: --- → +
The minidump is zero bytes, FYI (that's what the "ERROR: ReadBytes: read 0/32" means).
(Reporter)

Comment 3

3 years ago
This is a general Windows e10s crash being tracked in other bugs already.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: crash, intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1242221
You need to log in before you can comment on or make changes to this bug.