"content is null" exceptions from browser-gestureSupport.js in e10s mode

RESOLVED DUPLICATE of bug 1108553

Status

()

RESOLVED DUPLICATE of bug 1108553
3 years ago
3 years ago

People

(Reporter: bzbarsky, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

I have Firefox set to switch tabs when doing a twist on the trackpad: "browser.gesture.twist.left" is set to "Browser:PrevTab" and "browser.gesture.twist.right" is set to "Browser:NextTab".

When I do those gestures, I get errors like this in the error console:

  TypeError: content is null

with this stack:

  gGestureSupport.rotateEnd() browser-gestureSupport.js:467
  oncommand()
  ...(rest is not imporant)

The rotate/rotateEnd functions there directly poke at "content" for all sorts of stuff, which isn't going to work in e10s.
tracking-e10s: --- → ?
Blocks: 984139
tracking-e10s: ? → +

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1108553
You need to log in before you can comment on or make changes to this bug.