Closed Bug 1253901 Opened 4 years ago Closed 4 years ago

Update gcli script versions to jQuery 2.2.0, Lodash 4.6.1, and Underscore 1.8.3

Categories

(DevTools Graveyard :: Graphic Commandline and Toolbar, defect, P2)

defect

Tracking

(firefox44 wontfix, firefox45 wontfix, firefox46 wontfix, firefox47 fixed, firefox48 fixed)

RESOLVED FIXED
Firefox 48
Tracking Status
firefox44 --- wontfix
firefox45 --- wontfix
firefox46 --- wontfix
firefox47 --- fixed
firefox48 --- fixed

People

(Reporter: cpeterson, Assigned: cpeterson)

References

Details

Attachments

(1 file)

jQuery 2.1.1 -> 2.2.0
Lodash 2.4.1 -> 4.6.1
Underscore 1.7.0 -> 1.8.3

https://ajax.googleapis.com/ajax/libs/jquery/2.2.0/jquery.min.js
https://cdnjs.cloudflare.com/ajax/libs/lodash.js/4.6.1/lodash.min.js
https://cdnjs.cloudflare.com/ajax/libs/underscore.js/1.8.3/underscore-min.js

Is there any reason to prefer the Google-hosted jQuery? cdnjs has a more recent version (2.2.1) and is updated more frequently.

Is this change worth uplifting to Aurora 47 or even Beta 46?
Attachment #8727146 - Flags: review?(jwalker)
Comment on attachment 8727146 [details] [diff] [review]
update-gcli-script-versions.patch

Review of attachment 8727146 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks Chris,
LGTM, but forwarding r? to :gl who wrote this in the first place
Attachment #8727146 - Flags: review?(jwalker) → review?(gl)
Comment on attachment 8727146 [details] [diff] [review]
update-gcli-script-versions.patch

Review of attachment 8727146 [details] [diff] [review]:
-----------------------------------------------------------------

I think the changes are good. I think we can switch to cdnjs for jquery as well. I don't think there was any particular reason why we didn't use cdnjs at the time, but possibly because I just couldn't find the latest version at the time of writing the initial feature.
Attachment #8727146 - Flags: review?(gl) → review+
It might be worthwhile to uplift as well.
Thanks, Gabriel. I'll change the jquery link to (the latest version) on cdnjs and then request uplift to Aurora.
https://hg.mozilla.org/mozilla-central/rev/ae16b59ad280
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
Comment on attachment 8727146 [details] [diff] [review]
update-gcli-script-versions.patch

Approval Request Comment
[Feature/regressing bug #]: N/A
[User impact if declined]: Web developers using Dev Tools' "gcli inject" test command will be old versions of some popular JavaScript libraries.
[Describe test coverage new/current, TreeHerder]: These JavaScript libraries are very popular and (presumably :) stable.
[Risks and why]: Low risk because Firefox itself does not depend on these libraries. They are a convenience for web developers.
[String/UUID change made/needed]: N/A

jQuery 2.1.1 -> 2.2.0
Lodash 2.4.1 -> 4.6.1
Underscore 1.7.0 -> 1.8.3
Attachment #8727146 - Flags: approval-mozilla-aurora?
Attachment #8727146 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.