[flexbox] Overflow handling on fixed-height flex container having flex child with "overflow-y: scroll"

RESOLVED DUPLICATE of bug 1251059

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1251059
2 years ago
2 years ago

People

(Reporter: r.i.k, Unassigned)

Tracking

({testcase})

44 Branch
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160209234642

Steps to reproduce:

http://jsfiddle.net/9kdj41rh/9/

In this scenario, flexbox container has initially a height of 280px, and we **want** to have a scrollbar (even not scrollable if content is to small) on ".child.flex" child 
However, the flexible ".child.flex" child has no scrollbar (but is scrollable with mousewheel), despite the "overflow-y: scroll" CSS attribute
If we change the flexbox container height to 290px, the scrollbar appears... WHY ONLY NOW ???
If we change the flexbox container height to 400px, the scrollbar is OK (and not scrollable, since content fits)



Actual results:

The flex child has sometimes a visible scrollbar, sometimes not, depending of the fixed height of its container


Expected results:

The flex child should always have a visible scrollbar, independently of the fixed height of its container

Updated

2 years ago
Component: Untriaged → Layout
Keywords: testcase
Product: Firefox → Core
There is a scroll frame for the item, although both scrollbars have zero size (in one axis)
as if it where overflow:hidden.  Changing "overflow-y:scroll" to "overflow:scroll" makes
the horizontal scrollbar have non-zero size (according to frame dumps), and there is a blank
area at the bottom of the item clipping the text.  There is no visible scrollbar though,
as if it's not painted or something.  Weird...
Flags: needinfo?(dholbert)
Summary: Overflow handling on fixed-height flex container having flex child with "overflow-y: scroll" → [flexbox] Overflow handling on fixed-height flex container having flex child with "overflow-y: scroll"
(I actually can't directly reproduce, on my Ubuntu 64-bit linux machine -- I see a scrollbar (on the 3rd item) in comment 0's jsfiddle. But, it goes away if I reduce the height from 280px to 270px.  So I can basically reproduce, but my system just has a slightly-smaller threshold.)

I think this is the same general issue as described in bug 1251059. See testcases there -- we seem to hide scrollbars if a scrollable element is smaller than a certain size. (and it doesn't depend on flexbox styling)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(dholbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 1251059
You need to log in before you can comment on or make changes to this bug.