Crash when clicking button with malformed onClick handler

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: justdave, Assigned: jst)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.8+)
Gecko/20020209
BuildID:    2002020903 cfm

Mozilla crashes when I click a button with a bad onClick handler (that's my
guess anyway - further analysis by others may indicate another source for the
problem).

Reproducible: Always
Steps to Reproduce:
1. Visit the attached URL
2. fill in any valid postal address for a location
3. Click the Search button at the bottom of the page.
4. When the search results appear, a Javascript-created window pops up with a
disclaimer about the accuracy of the directory.  Click the OK button in that
window, and Mozilla goes boom.  "The application Mozilla has unexpectedly quit"

Actual Results:  Mozilla crashes.

Expected Results:  Maybe I get a Javascript error, or it just fails to execute
the bad script.

I will attempt to attach page source for the popup window and a stack trace if I
can get one in a few minutes.
Created attachment 69391 [details]
HTML source of the popup window
Created attachment 69413 [details]
Crash log from CrashReporter
Attachment #69413 - Attachment mime type: application/octet-stream → text/plain
I can reliably reproduce this by VIEWING the first attachment on this bug, and
clicking the OK button from there.  Editing that attachment and clicking the OK
button in the IFRAME on the right does not result in a crash.
(Assignee)

Comment 4

17 years ago
Hmm, I can't reproduce this with todays build, anyone else?
Confirmed.  Crash is gone with today's build. :)
(Assignee)

Comment 6

17 years ago
WORKSFORME then. Thanks for testing.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.