No warning message displayed when trying to sign up for MP newsletter without an e-mail

VERIFIED FIXED in 2016-03-29

Status

P3
normal
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: valentina.peleskei, Assigned: spasovski)

Tracking

Avenir
2016-03-29
x86_64
Windows 7
Points:
---

Details

(Whiteboard: [ktlo])

(Reporter)

Description

3 years ago
Steps to reproduce:
1. Load MP-stage page https://marketplace.allizom.org/
2. Go to page footer
3. Click the "Sign me up" button from the Newsletter section
4. Observe the e-mail warning message 

Expected results:
"Please fill out this field" message is displayed.

Actual results:
No warning message displayed.

Notes/Issues:
The issue is not reproducing on FF OS.
Verified on FF47(Win 7). Issue is reproducing on MP-stage, dev and prod.
Screenshot for this issue: http://screencast.com/t/lGkDSw37oBVb
(Reporter)

Comment 1

3 years ago
On FF OS 2.1 if there is no e-mail address in the field and the "Sign me up" button is clicked: the field is made smaller. Please see the screenshot: http://screencast.com/t/AHHELnca
The email field returns to its regular size when entering a longer email and clicking "Sign me up" again.
Looks  like we're supposed to have a string in that red callout. There's text there, but I guess CSS is scrunching the balloon and (effectively) hiding it?
Assignee: nobody → dspasovski
Priority: -- → P3
Whiteboard: [ktlo]
(Assignee)

Comment 3

2 years ago
https://github.com/mozilla/fireplace/commit/9a58a10
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

2 years ago
The issue from comment #0 is still reproducible on MP-dev FF48(Win 7) - http://screencast.com/t/OnfWbAwj

The issue from comment #1 was verified as fixed on FF OS 2.1(Flame) - http://screencast.com/t/pWNqmRxb4bh

I guess this is actually my bad, because I mentioned two issues in one.
Being in the same section... that was my call.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

2 years ago
Good call, this was only happening on desktop but fixed now.

https://github.com/mozilla/fireplace/commit/41b8e0e
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

2 years ago
Verified as fixed on MP-dev FF48(Win 7).
Postfix screenshot: http://screencast.com/t/GLws0k8ewNt
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.