[TV][Home] Move rename, rearrange, and delete from edit mode to context menu.

RESOLVED FIXED

Status

Firefox OS
Gaia::TV::Home
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: rexboy, Assigned: Fischer)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.6+)

Details

(Whiteboard: [ft:conndevices])

Attachments

(2 attachments)

In v2.6, we decide to remove rename, rearrange, and delete features to context menu.

Then we no longer enter edit mode directly.
(Assignee)

Updated

2 years ago
Assignee: nobody → fliu

Updated

2 years ago
blocking-b2g: --- → 2.6+
Whiteboard: [ft:conndevices]

Comment 1

2 years ago
Hi Fischer,
Could you provide a target milestone?
Thanks
Flags: needinfo?(fliu)
(Assignee)

Comment 2

2 years ago
Target to have the function implementation done and get into code review this week.
However, some UI styles are not yet ready so the UI styles would be done in another bug once ready.
Flags: needinfo?(fliu)
(Assignee)

Updated

2 years ago
Blocks: 1264167
(Assignee)

Updated

2 years ago
No longer blocks: 1264167
Depends on: 1264167

Comment 3

2 years ago
Created attachment 8742185 [details] [review]
[gaia] Fischer-L:bug_1254039-home-context-menu > mozilla-b2g:master
(Assignee)

Comment 4

2 years ago
Comment on attachment 8742185 [details] [review]
[gaia] Fischer-L:bug_1254039-home-context-menu > mozilla-b2g:master

@Rex,

This patch

- Enable context menu based on app type to edit cards in smart home:
  - deck type: move,
  - folder type: move, edit folder,
  - tv, app, appbookmark: move, rename, remove

- Context menu only can be triggered in the normal state

- Remove the edit button so as to enter edit mode only through context menu

Thanks
Attachment #8742185 - Flags: review?(rexboy)
Comment on attachment 8742185 [details] [review]
[gaia] Fischer-L:bug_1254039-home-context-menu > mozilla-b2g:master

This patch is going on a direction that I didn't expected.

Let's have some discussion tomorrow.
Attachment #8742185 - Flags: review?(rexboy)
(Assignee)

Comment 6

2 years ago
Comment on attachment 8742185 [details] [review]
[gaia] Fischer-L:bug_1254039-home-context-menu > mozilla-b2g:master

@Rex,

Update the patch to 
- Move focus handling during enter.exiting the edit mode inside the toggleEditMode method.
- Use event instead of Promise to reduce the complexity of removing card job.

Thanks
Attachment #8742185 - Flags: review?(rexboy)
Comment on attachment 8742185 [details] [review]
[gaia] Fischer-L:bug_1254039-home-context-menu > mozilla-b2g:master

Much better but I think we can make things easier. See my comments on Github.
Attachment #8742185 - Flags: review?(rexboy)

Updated

2 years ago
Blocks: 1267117
(Assignee)

Comment 8

2 years ago
Comment on attachment 8742185 [details] [review]
[gaia] Fischer-L:bug_1254039-home-context-menu > mozilla-b2g:master

@Luke,

This patch has been updated based on Rex's suggestions:
- Skip entering the edit mode and rename/unpin card directly
- Bind contextmenu to folder-list and card-list to eliminate the handling of disable contextmenu when showing card picker.

Please have a look.

Thank you.
Attachment #8742185 - Flags: review?(lchang)

Comment 9

2 years ago
Comment on attachment 8742185 [details] [review]
[gaia] Fischer-L:bug_1254039-home-context-menu > mozilla-b2g:master

Great work! Thanks.
Attachment #8742185 - Flags: review?(lchang) → review+

Comment 10

2 years ago
Created attachment 8745950 [details] [review]
[gaia] Fischer-L:bug_1254039-home-context-menu > mozilla-b2g:v2.6
(Assignee)

Comment 11

2 years ago
Land to v2.6: https://github.com/mozilla-b2g/gaia/commit/ed6a23e58012b500299c8ae6415063af16b21240
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1256262

Updated

2 years ago
Duplicate of this bug: 1267117
You need to log in before you can comment on or make changes to this bug.