latest build mozilla crashes while visiting xbox-scene.com [nsHttpHandler::GetConnection_Locked]

RESOLVED DUPLICATE of bug 91429

Status

()

P1
critical
RESOLVED DUPLICATE of bug 91429
17 years ago
17 years ago

People

(Reporter: michel.rooman, Assigned: badami)

Tracking

({crash})

Trunk
mozilla0.9.9
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020213
BuildID:    2002021303

When I visit www.xbox-scene.com they browser crashes from time to time. Isn't on
any specific url , nor after any specific action I think.
Here are 2 Netscape Q feebbacks # :
TB2885457Y
TB2886136X

Reproducible: Sometimes
Steps to Reproduce:
1.go to www.xbox-scene.com
2.visit some pages
3.

Actual Results:  Mozilla crash ("this programs has made an illegal operation...")

Expected Results:  display webpage

Comment 1

17 years ago
Stephen, can you pull TB2886136X ?

nsHttpHandler::GetConnection_Locked
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpHandler.cpp, line 717]
nsHttpHandler::InitiateTransaction
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpHandler.cpp, line 409]
necko.dll + 0x409a0 (0x609109a0)
nsFileProtocolHandler::AddRef
[d:\builds\seamonkey\mozilla\netwerk\protocol\file\src\nsFileProtocolHandler.cpp,
line 78]
nsHttpTransaction::Release
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpTransaction.cpp,
line 690]
nsHttpTransaction::SetSecurityInfo
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpTransaction.h, line 82]
nsHttpTransaction::IsDone
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpTransaction.h, line 88]
nsFileChannel::QueryInterface
0x85107d8b 
Keywords: crash

Comment 3

17 years ago
-> networking http
Component: Browser-General → Networking: HTTP
Summary: latest build mozilla crashes while visiting xbox-scene.com → latest build mozilla crashes while visiting xbox-scene.com [nsHttpHandler::GetConnection_Locked]

Comment 4

17 years ago
.
Assignee: asa → darin
QA Contact: doronr → tever
Confirming with build 2002-02-13-08 - I also crash 100% on
http://www.vignette.com (but on Linux).
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Stack Signature  nsHttpHandler::GetConnection_Locked() 500ba5d8
Trigger Time 2002-02-14 02:13:50
Email Address stephend@netscape.com
URL visited http://www.vignette.com
Build ID 2002021308
Product ID MozillaTrunk
Platform
Operating System LinuxIntel
Module
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11)
User Comments
Stack Trace
nsHttpHandler::GetConnection_Locked()
nsHttpHandler::InitiateTransaction()
nsHttpChannel::Connect()
nsHttpChannel::AsyncOpen()
imgLoader::LoadImage()
nsHTMLImageElement::SetSrcInner()
nsHTMLImageElement::SetSrc()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
XPC_WN_GetterSetter()
js_Invoke()
js_InternalInvoke()
js_SetProperty()
js_Interpret()
js_Execute()
JS_EvaluateUCScriptForPrincipals()
nsJSContext::EvaluateString()
nsScriptLoader::EvaluateScript()
nsScriptLoader::ProcessRequest()
nsScriptLoader::ProcessScriptElement()
nsHTMLScriptElement::SetDocument()
nsGenericHTMLContainerElement::AppendChildTo()
HTMLContentSink::ProcessSCRIPTTag()
HTMLContentSink::AddLeaf()
CNavDTD::AddLeaf()
CNavDTD::HandleScriptToken()
CNavDTD::OpenContainer()
CNavDTD::HandleDefaultStartToken()
CNavDTD::HandleStartToken()
CNavDTD::HandleToken()
CNavDTD::BuildModel()
nsParser::BuildModel()
nsParser::ResumeParse()
nsParser::ContinueParsing()
HTMLContentSink::ScriptEvaluated()
nsScriptLoader::FireScriptEvaluated()
nsScriptLoader::ProcessRequest()
nsScriptLoader::OnStreamComplete()
nsStreamLoader::OnStopRequest()
nsStreamListenerTee::OnStopRequest()
nsHttpChannel::OnStopRequest()
nsOnStopRequestEvent::HandleEvent()
nsARequestObserverEvent::HandlePLEvent()
PL_HandleEvent()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
our_gdk_io_invoke()
libglib-1.2.so.0 + 0xea7a (0x40392a7a)
libglib-1.2.so.0 + 0x10055 (0x40394055)
libglib-1.2.so.0 + 0x10659 (0x40394659)
libglib-1.2.so.0 + 0x107e8 (0x403947e8)
libgtk-1.2.so.0 + 0x9127b (0x402b027b)
nsAppShell::Run()
nsAppShellService::Run()
netscape-bin + 0x7e49 (0x0804fe49)
netscape-bin + 0x8697 (0x08050697)
libc.so.6 + 0x1c306 (0x404f1306) 

Comment 7

17 years ago
seems very reproducible in the 2/13 linux build... cannot repro in the 2/12 build.
i'm suspecting this might be related to vinay's patch for bug 91429 since that
appears to be the only thing that has changed in the related HTTP code since the
2/12 build.

Comment 8

17 years ago
-> 0.9.9
Keywords: mozilla0.9.9
Priority: -- → P1
Target Milestone: --- → mozilla0.9.9
(Reporter)

Comment 9

17 years ago
I found another URL where it crashes (http://www.xboxtop20.com/) (on mainpage) ,
but I'm still unable to give any specific moment when it crashes , seems really
random ... but on this page it crashes more often then on the previous page I
gave(like 1 out of 3 times).
Some Netscape Feebbacks for this URL :
TB2925401Y
TB2925405Z

Like said above ... older build don't seem to crash (I reinstalled 20020210 rls
and it didn't crash any time on those 3 URL's)

Comment 10

17 years ago
-> badami for investigation
Assignee: darin → badami
(Assignee)

Comment 11

17 years ago
The patch for  bug 91429 was using RemoveElement instead of RemoveElementAt.
With that patch I'am able to browse 
http://www.vignette.com
http://www.xboxtop20.com/





*** This bug has been marked as a duplicate of 91429 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.