Advanced search: Show list of inputs available for "white board" field

RESOLVED WONTFIX

Status

()

Bugzilla
Query/Bug List
P5
enhancement
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: chaithanya, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160125133825

Steps to reproduce:

These are the following steps to reproduce:
1.Choose search a bug.
2. Click on advanced search
3.Go to detailed information
4.Give inputs in whiteboard field. 


Actual results:

You will notice that the user is not provided with any options unlike the keyword field.


Expected results:

A list of whiteboard input field options should appear in a scroll bar menu similar to the keyword field.

Comment 1

2 years ago
As the whiteboard provides free-form input (in contrast to the keywords field which has globally configured values) I don't see how to provide such functionality in a performant or even useful way - just because one random user ever added "abcxyz" to the whiteboard of a single bug and another one added "xyzabc", why should those values be displayed?
I don't see how this request helps when it comes to the specific use case of the whiteboard. 
Please elaborate.

Severity = enhancement. (New feature/functionality request and not a bug.)
Severity: normal → enhancement
Flags: needinfo?(chaitanya7991)

Updated

2 years ago
Summary: During advanced search of the bug in the detailed description, the white board field does not show a list of inputs available unlike the keyword field. → Advanced search: Show list of inputs available for "white board" field
(Reporter)

Comment 2

2 years ago
When the user adds "xyzabc" the whiteboard input can search for similar input fields and that can be listed. Or atleast an input field for finding bugs under "simple"/ "medium" /"trival" can be added.
Flags: needinfo?(chaitanya7991)

Comment 3

2 years ago
(In reply to chaithanya from comment #2)
> When the user adds "xyzabc" the whiteboard input can search for similar
> input fields and that can be listed.

Why? Please provide a specific use case of what specifically you would like to achieve, and why this would be helpful.

> Or atleast an input field for finding bugs under "simple"/ "medium" /"trival" can be added.

What is ""simple"/ "medium" /"trival""? Are these values of some field?
Flags: needinfo?(chaitanya7991)

Updated

2 years ago
Assignee: general → query-and-buglist
Component: Bugzilla-General → Query/Bug List
(Reporter)

Comment 4

2 years ago
For newcomers, they probably wouldn't be having any idea to find an easy fix out of the several ones listed in the bugs@mozilla page. Hence it would be a good idea to have an input field which would accept and list keywords like "simple"/ "medium"/"trivial" depending on the severity of the bug. 

Hence I thought it would be a good idea to incorporate this feature in the already existing Whiteboard input field.
Flags: needinfo?(chaitanya7991)

Comment 5

2 years ago
(In reply to chaithanya from comment #4)
> For newcomers, they probably wouldn't be having any idea to find an easy fix
> out of the several ones listed in the bugs@mozilla page.

I do not know where or what that page is. Please provide references for statements.

> Hence it would be a
> good idea to have an input field which would accept and list keywords like
> "simple"/ "medium"/"trivial" depending on the severity of the bug. 

Keywords are expressed in the "keywords" field, not as whiteboard entries, and severity is expressed in the "Severity" field already. I'm afraid I cannot follow your argumentation...
Flags: needinfo?(chaitanya7991)
(Reporter)

Comment 6

2 years ago
While searching for a bug in bugs@mozilla, "whiteboard" input filed is a free form field. It could be made user friendly if it could auto fill the words as the user begins to give inputs. For example, if a user wants to find easy bugs, so he/she types "good" and automatically the "whiteboard" input field fills the rest for the user with "good first bug". This could be pretty useful for newbies.
Flags: needinfo?(chaitanya7991)

Comment 7

2 years ago
(In reply to chaithanya from comment #6)
> For example, if a user wants to
> find easy bugs, so he/she types "good" and automatically the "whiteboard"
> input field fills the rest for the user with "good first bug".

The problem is that a free text form has no predefined values. This means that there is no reason for Bugzilla to associate "good" with "good first bug". It would return *all* strings containing "good" in them, which would make the list to be huge and pretty useless.
Priority: -- → P5
(Reporter)

Comment 8

2 years ago
It was only a suggestion. :) I thought it would make it easier to find good first bugs for newbies.

Comment 9

2 years ago
Yes, I understand. But I think the benefit is too low to be implemented. :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.