Clipboard cache shouldn't be saved out of the users context

UNCONFIRMED
Unassigned

Status

()

Core
Widget
P1
enhancement
UNCONFIRMED
2 years ago
4 days ago

People

(Reporter: sworddragon2, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tpi:+)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160304115459

Steps to reproduce:

Select a long text (for example by generating enough content in a textfield; 1+ MiB seems to be enough) and make a look at /tmp.


Actual results:

In /tmp the file clipboardcache and for every additional selection files in the form of clipboardcache-n are created.


Expected results:

1. Since selecting any text could also contain private data and this selection is user-specific it should be maybe saved in the user profile (or the XDG cache directory if such a sort of cache would fit in there) and not in /tmp.
2. An option to disable this behavior could be helpful too.


Additional information:

I'm not sure why Firefox does provide more or less funtionality for a primary clipboard as userspace-packages of Linux distributions do normally provide this functionality.
(Reporter)

Updated

2 years ago
Severity: normal → enhancement

Updated

2 years ago
Component: Untriaged → Networking: Cache
Product: Firefox → Core
Hmm?
Component: Networking: Cache → XUL

Updated

2 years ago
Component: XUL → Widget

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 335545
(Reporter)

Comment 3

2 years ago
Not a duplicate as this report claims about that the clipboard cache is saved out of the users context while the other report claims that the files are not deleted at all.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

2 years ago
(In reply to sworddragon2 from comment #3)
> Not a duplicate as this report claims about that the clipboard cache is
> saved out of the users context while the other report claims that the files
> are not deleted at all.

I don't see how this is different. Creating the file and not removing it are the issue, and I think bug 335545 covers that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 335545
(Reporter)

Comment 5

2 years ago
The difference is that the users home might be better protected than /tmp for example with encryption, more strict access controls, etc. At the time these files exists in /tmp they have more potential to leak its data and even if Firefox deletes them they might get recovered while this would not be possible if stored somewhere in the encrypted home directory.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Clipboard cache can leak private data → Clipboard cache shouldn't be saved out of the users context

Updated

2 years ago
Depends on: 335545
Priority: -- → P1
Whiteboard: tpi:+

Updated

8 months ago
See Also: → bug 1396224
You need to log in before you can comment on or make changes to this bug.