Text chat notification when user joins room

RESOLVED FIXED

Status

Hello (Loop)
Client
P2
normal
Rank:
29
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: fcampo, Assigned: fcampo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [btpp-fix-later][ux-triage])

Attachments

(3 attachments)

(Assignee)

Description

2 years ago
Created attachment 8727367 [details]
friend left but still writes.png

Besides the system notifications, it would be useful to have a message on the chat for keeping track of the user at the other end connection/disconnection.

We have already a message when a friend leaves, but not when joins again, so the text chat history seems weird if a user disconnects, connects again and writes something.
(Assignee)

Updated

2 years ago
Flags: needinfo?(sfranks)
Flags: needinfo?(b.pmm)
Yes, agreed. Can probably just mirror the image and say "Your friend has joined."
Flags: needinfo?(sfranks)
Flags: needinfo?(b.pmm)

Updated

2 years ago
Rank: 29
Priority: -- → P2

Updated

2 years ago
Whiteboard: [btpp-fix-later]

Updated

2 years ago
Whiteboard: [btpp-fix-later] → [btpp-fix-later][ux-triage]
Duplicate of this bug: 1266373

Comment 3

2 years ago
Created attachment 8748626 [details] [review]
[loop] fcampo:joined-peer-message-1254097 > mozilla:master
(Assignee)

Comment 4

2 years ago
Created attachment 8748630 [details]
patched-UX
Attachment #8748630 - Flags: ui-review?(sfranks)
Attachment #8748630 - Flags: ui-review?(b.pmm)
(Assignee)

Updated

2 years ago
Attachment #8748626 - Flags: review?(dcritchley)
Attachment #8748626 - Flags: review?(crafuse)
(Assignee)

Updated

2 years ago
Assignee: nobody → fernando.campo
Status: NEW → ASSIGNED

Comment 5

2 years ago
Comment on attachment 8748630 [details]
patched-UX

It's fine for now. When we get the new visuals for Akita it'll probably change a bit. Thanks Fernando!
Attachment #8748630 - Flags: ui-review?(sfranks)
Attachment #8748630 - Flags: ui-review?(b.pmm)
Attachment #8748630 - Flags: ui-review+
Comment on attachment 8748626 [details] [review]
[loop] fcampo:joined-peer-message-1254097 > mozilla:master

Looks good, Going to run tests.
Attachment #8748626 - Flags: review?(dcritchley)
Comment on attachment 8748626 [details] [review]
[loop] fcampo:joined-peer-message-1254097 > mozilla:master

Once rebased to master should be good to go. r=crafuse.
Attachment #8748626 - Flags: review?(crafuse) → review+
(Assignee)

Comment 8

2 years ago
https://github.com/mozilla/loop/commit/eba93ea2e009f6d61e2792fd7b54940ab8527751
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Blocks: 1273671
You need to log in before you can comment on or make changes to this bug.