Closed Bug 12542 Opened 21 years ago Closed 21 years ago

[4.xP]line numbers not reported for errors in event attributes

Categories

(Core :: JavaScript Engine, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 11240

People

(Reporter: dbaron, Assigned: mike+mozilla)

Details

Attachments

(2 files)

DESCRIPTION:  Javascript errors within event handler attributes don't report
file name and line number, only the error.

STEPS TO REPRODUCE:  Load either attached test case.

ACTUAL RESULTS:  Text window shows:

JavaScript error: test is not defined

EXPECTED RESULTS:  Text window should show something more like:

http://bugzilla.mozilla.org/showattachment.cgi?attach_id=????, line No. ??
JavaScript error: test is not defined

DOES NOT WORK CORRECTLY ON:
 * Linux, viewer, 1999-08-24-08-M10

WORKS CORRECTLY ON:
 * Linux, NN 4.6 (in "javascript:")
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → INVALID
bugzilla is for bugs he mozilla product. see
http://www.mozilla.org/quality/bug-writing-guidelines.html

for 4.x bugs, you should file bugs here:
http://help.netscape.com/forms/bug-client.html
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
I know that.  Please read the bug more carefully.  [4.xP] is the code for
4.x-Parity, i.e., something that works in 4.x and doesn't in Mozilla.
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 11240 ***
Status: RESOLVED → VERIFIED
verified dup
You need to log in before you can comment on or make changes to this bug.