Please deploy loop standalone 1.1.10 to PRODUCTION

RESOLVED FIXED

Status

Cloud Services
Operations: Deployment Requests
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: rpapa, Assigned: jp)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

------------------
RELEASE NOTES
------------------
https://github.com/mozilla/loop/releases

COMPARISONS
https://github.com/mozilla/loop/compare/v1.1.7...v1.1.9
https://github.com/mozilla/loop/compare/v1.1.9...v1.1.10

TAGS
https://github.com/mozilla/loop/releases/tag/v1.1.10
https://github.com/mozilla/loop/commit/8cd69ef717ff3118eb2dd27c1eee3f0d71e04eba
Assignee: nobody → chartjes
Depends on: 1253414
Assignee: chartjes → jschneider
QA Contact: chartjes
here's what's currently in production prior to deployment....

----------------------------
URL CHECKS (PROD)
----------------------------

https://hello.firefox.com:
Request was redirected!
status code: 200 --> destination: https://www.mozilla.org/en-US/firefox/hello/

Response time: 0.006516


https://hello.firefox.com/config.js:
var loop = loop || {};

loop.config = {
  serverUrl: 'https://loop.services.mozilla.com/v0',
  feedbackApiUrl: 'https://input.mozilla.org/api/v1/feedback',
  feedbackProductName: 'Loop',
  downloadFirefoxUrl: 'https://www.mozilla.org/firefox/new/?scene=2&utm_source=hello.firefox.com&utm_medium=referral&utm_campaign=non-webrtc-browser\#download-fx',
  privacyWebsiteUrl: 'https://www.mozilla.org/privacy/firefox-hello/',
  legalWebsiteUrl: 'https://www.mozilla.org/about/legal/terms/firefox-hello/',
  marketplaceUrl: 'https://marketplace.firefox.com/iframe-install.html',
  learnMoreUrl: 'https://www.mozilla.org/hello/',
  roomsSupportUrl: 'https://support.mozilla.org/kb/group-conversations-firefox-hello-webrtc',
  guestSupportUrl: 'https://support.mozilla.org/kb/respond-firefox-hello-invitation-guest-mode',
  generalSupportUrl: 'https://support.mozilla.org/kb/respond-firefox-hello-invitation-guest-mode',
  unsupportedPlatformUrl: 'https://support.mozilla.org/kb/which-browsers-will-work-firefox-hello-video-chat',
  tilesIframeUrl: 'https://tiles.cdn.mozilla.net/iframe.html',
  tilesSupportUrl: 'https://support.mozilla.org/kb/tiles-firefox-hello',
  fxosApp: {
    name: 'Firefox Hello',
    manifestUrl: 'https://marketplace.firefox.com/app/54b83aea-1208-4605-82eb-22819f39d81d/manifest.webapp',
    rooms: false
  }
};

Response time: 0.140903


https://loop.services.mozilla.com:
{
    "endpoint": "https://loop.services.mozilla.com", 
    "name": "mozilla-loop-server", 
    "fakeTokBox": false, 
    "fxaOAuth": true, 
    "version": "0.20.0-dev", 
    "i18n": {
        "defaultLang": "en-US"
    }, 
    "homepage": "https://github.com/mozilla-services/loop-server/", 
    "description": "The Mozilla Loop (WebRTC App) server"
}
Response time: 0.166598


https://loop.services.mozilla.com/push-server-config:
{
    "pushServerURI": "wss://push.services.mozilla.com"
}
Response time: 0.1514
(Assignee)

Comment 2

2 years ago
New stack:

"output": "Stack CREATE complete", "stack_outputs": {"ELB": "loopclientprod-ELB-1VMPGFFIRPNX", "ELBFQDN": "loopclientprod-ELB-1VMPGFFIRPNX-802099420.us-west-2.elb.amazonaws.com", "HTTPSURL": "https://loopclientprod-ELB-1VMPGFFIRPNX-802099420.us-west-2.elb.amazonaws.com"}}
==================================
PRE-PROD (INCOMING) STACK
==================================

this is incoming stack (pre-deployment):

NOTE:
Content-Security-Policy and https://*.optimizely.com now in place.

------------------
E2E-TESTS
------------------

Placed several calls successfully between Gen Release (47.0a1) and General Release (44.0.2).

end-2-end test calls (shared URL) - OK
Video/audio mute/unmute - OK
messaging - OK 
Tab & window-sharing - OK
privacy & ToS links - OK
Feedback screens - OK
push notifications - OK


----------------------------
URL CHECKS (PRE-PROD)
----------------------------

https://hello.firefox.com:
Request was redirected!
status code: 200 --> destination: https://www.mozilla.org/en-US/firefox/hello/


https://hello.firefox.com/config.js:
var loop = loop || {};

loop.config = {
  serverUrl: 'https://loop.services.mozilla.com/v0',
  feedbackApiUrl: 'https://input.mozilla.org/api/v1/feedback',
  feedbackProductName: 'Loop',
  downloadFirefoxUrl: 'https://www.mozilla.org/firefox/new/?scene=2&utm_source=hello.firefox.com&utm_medium=referral&utm_campaign=non-webrtc-browser\#download-fx',
  privacyWebsiteUrl: 'https://www.mozilla.org/privacy/firefox-hello/',
  legalWebsiteUrl: 'https://www.mozilla.org/about/legal/terms/firefox-hello/',
  marketplaceUrl: 'https://marketplace.firefox.com/iframe-install.html',
  learnMoreUrl: 'https://www.mozilla.org/hello/',
  roomsSupportUrl: 'https://support.mozilla.org/kb/group-conversations-firefox-hello-webrtc',
  guestSupportUrl: 'https://support.mozilla.org/kb/respond-firefox-hello-invitation-guest-mode',
  generalSupportUrl: 'https://support.mozilla.org/kb/respond-firefox-hello-invitation-guest-mode',
  unsupportedPlatformUrl: 'https://support.mozilla.org/kb/which-browsers-will-work-firefox-hello-video-chat',
  tilesIframeUrl: 'https://tiles.cdn.mozilla.net/iframe.html',
  tilesSupportUrl: 'https://support.mozilla.org/kb/tiles-firefox-hello',
  fxosApp: {
    name: 'Firefox Hello',
    manifestUrl: 'https://marketplace.firefox.com/app/54b83aea-1208-4605-82eb-22819f39d81d/manifest.webapp',
    rooms: false
  }
};

NOTE: Known issue with latest release of loop-server having been incorrectly
tagged as 0.20.0-dev, it is 0.19.3 running in production

https://loop.services.mozilla.com:
{
    "description": "The Mozilla Loop (WebRTC App) server",
    "endpoint": "https://loop.services.mozilla.com",
    "fakeTokBox": false,
    "fxaOAuth": true,
    "homepage": "https://github.com/mozilla-services/loop-server/",
    "i18n": {
        "defaultLang": "en-US"
    },
    "name": "mozilla-loop-server",
    "version": "0.20.0-dev"
}

https://loop.services.mozilla.com/push-server-config
{
    "pushServerURI": "wss://push.services.mozilla.com"
}

$ curl -i -k https://hello.firefox.com
HTTP/1.1 301 Moved Permanently
Content-Security-Policy: frame-ancestors 'self'; default-src 'self'; img-src 'self' data: https://www.gravatar.com/ https://www.google-analytics.com https://stats.g.doubleclick.net; font-src 'none'; frame-src 'self' https://tiles.cdn.mozilla.net; connect-src 'self' wss://*.tokbox.com https://*.opentok.com https://*.tokbox.com wss://*.mozilla.com https://*.mozilla.com https://*.mozilla.org wss://*.mozaws.net https://*.mozaws.net; media-src 'self' blob:; script-src 'self' 'unsafe-inline' 'unsafe-eval' https://*.optimizely.com https://www.google-analytics.com; style-src 'self' about: 'unsafe-inline'; report-uri /__cspreporting__/
Content-Type: text/html
Date: Mon, 07 Mar 2016 21:39:24 GMT
Location: https://www.mozilla.org/firefox/hello/
X-Frame-Options: SAMEORIGIN
Content-Length: 178
Connection: keep-alive

<html>
<head><title>301 Moved Permanently</title></head>
<body bgcolor="white">
<center><h1>301 Moved Permanently</h1></center>
<hr><center>nginx</center>
</body>
</html>

QA verifies tests performed all pass.

Ready for DNS switch.
Status: NEW → ASSIGNED
==================================
PRODUCTION (RELEASE STACK)
==================================

------------------
E2E-TESTS
------------------

Placed several calls successfully between Gen Release (47.0a1) and General Release (44.0.2).

end-2-end test calls (shared URL) - OK
Video/audio mute/unmute - OK
messaging - OK 
Tab & window-sharing - OK
privacy, mozilla-support (? icon) & ToS links - OK
Feedback screens - OK
push notifications - OK

----------------------------
URL CHECKS (PROD)
----------------------------

https://hello.firefox.com:
Request was redirected!
status code: 200 --> destination: https://www.mozilla.org/en-US/firefox/hello/

https://hello.firefox.com/config.js:
var loop = loop || {};

loop.config = {
  serverUrl: 'https://loop.services.mozilla.com/v0',
  feedbackApiUrl: 'https://input.mozilla.org/api/v1/feedback',
  feedbackProductName: 'Loop',
  downloadFirefoxUrl: 'https://www.mozilla.org/firefox/new/?scene=2&utm_source=hello.firefox.com&utm_medium=referral&utm_campaign=non-webrtc-browser\#download-fx',
  privacyWebsiteUrl: 'https://www.mozilla.org/privacy/firefox-hello/',
  legalWebsiteUrl: 'https://www.mozilla.org/about/legal/terms/firefox-hello/',
  marketplaceUrl: 'https://marketplace.firefox.com/iframe-install.html',
  learnMoreUrl: 'https://www.mozilla.org/hello/',
  roomsSupportUrl: 'https://support.mozilla.org/kb/group-conversations-firefox-hello-webrtc',
  guestSupportUrl: 'https://support.mozilla.org/kb/respond-firefox-hello-invitation-guest-mode',
  generalSupportUrl: 'https://support.mozilla.org/kb/respond-firefox-hello-invitation-guest-mode',
  unsupportedPlatformUrl: 'https://support.mozilla.org/kb/which-browsers-will-work-firefox-hello-video-chat',
  tilesIframeUrl: 'https://tiles.cdn.mozilla.net/iframe.html',
  tilesSupportUrl: 'https://support.mozilla.org/kb/tiles-firefox-hello',
  fxosApp: {
    name: 'Firefox Hello',
    manifestUrl: 'https://marketplace.firefox.com/app/54b83aea-1208-4605-82eb-22819f39d81d/manifest.webapp',
    rooms: false
  }
};


NOTE: Known issue that the current production release of Loop server is
incorrectly tagged as version 0.20.0-dev. It is 0.19.3

https://loop.services.mozilla.com:
{
    "description": "The Mozilla Loop (WebRTC App) server",
    "endpoint": "https://loop.services.mozilla.com",
    "fakeTokBox": false,
    "fxaOAuth": true,
    "homepage": "https://github.com/mozilla-services/loop-server/",
    "i18n": {
        "defaultLang": "en-US"
    },
    "name": "mozilla-loop-server",
    "version": "0.20.0-dev"
}

https://loop.services.mozilla.com/push-server-config:
{
    "pushServerURI": "wss://push.services.mozilla.com"
}

$ curl -i https://hello.firefox.com
HTTP/1.1 301 Moved Permanently
Content-Security-Policy: frame-ancestors 'self'; default-src 'self'; img-src 'self' data: https://www.gravatar.com/ https://www.google-analytics.com https://stats.g.doubleclick.net; font-src 'none'; frame-src 'self' https://tiles.cdn.mozilla.net; connect-src 'self' wss://*.tokbox.com https://*.opentok.com https://*.tokbox.com wss://*.mozilla.com https://*.mozilla.com https://*.mozilla.org wss://*.mozaws.net https://*.mozaws.net; media-src 'self' blob:; script-src 'self' 'unsafe-inline' 'unsafe-eval' https://*.optimizely.com https://www.google-analytics.com; style-src 'self' about: 'unsafe-inline'; report-uri /__cspreporting__/
Content-Type: text/html
Date: Mon, 07 Mar 2016 22:11:52 GMT
Location: https://www.mozilla.org/firefox/hello/
X-Frame-Options: SAMEORIGIN
Content-Length: 191
Connection: keep-alive

<html>
<head><title>301 Moved Permanently</title></head>
<body bgcolor="white">
<center><h1>301 Moved Permanently</h1></center>
<hr><center>openresty/1.7.10.2</center>
</body>
</html>

QA verified all tests pass.

One grumpy thumb up!
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
I took a look this morning and realised that the expected version wasn't actually on production.

I was looking at a couple of bugs, and they just weren't there, e.g. visiting https://hello.firefox.com/js/standalone.js I searched for OpenTok and got 2.6.8 rather than 2.7.3. There were a couple of other visual changes as well that I could see were missing.

I confirmed with phrawzty over irc that the DNS was still pointing to the old elb. So something didn't get updated.

It looks like we need to try and include at least one visual change in the qa verification process so that we can be sure this has worked correctly.

I'm also hoping that you'll be able to run functional tests against the next release. In this case, these would have caught this issue (though I could see cases where we don't change the UI much, and they wouldn't catch it).
Status: VERIFIED → REOPENED
Flags: needinfo?(rpappalardo)
Flags: needinfo?(chartjes)
Resolution: FIXED → ---
Note: phrawzty and I are planning to push this out fully as soon as we're both about, so that we don't hit up against the Firefox releases that are happening today.
I switched the DNS to point at the newest deployed endpoint. Initial verifications w/ :standard8 indicate that this was indeed the issue.
I was just talking to Dan and realised that in moving repositories, we've managed to drop the VERSION.txt file that we used to have. I'm going to restore that in bug 1254517 for the next release.

I've done a few tests locally and using the in-development functional tests and the new production seems to be working fine now and has the right versions.

I'll leave it to Chris to decide if he wants to do more testing or not.
If we had the correct version on staging (which I tested) and pre-prod (which I tested) then I'm confident that no more testing is required.
Flags: needinfo?(chartjes)
Flags: needinfo?(rpappalardo)
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.