Closed Bug 1254264 Opened 6 years ago Closed 5 years ago

ssd.userbenchmark.com/Comparison is not scrolling smoothly

Categories

(Core :: Panning and Zooming, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1257369
Tracking Status
e10s + ---

People

(Reporter: marcino245, Unassigned)

References

()

Details

(Keywords: perf, regression, Whiteboard: gfx-noted)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

Steps to reproduce:

1) Go to ssd.userbenchmark.com/Comparison
2) Wait until it gets loaded
3) Scroll the webpage


Actual results:

The wepage is not scrolling smoothly


Expected results:

The wepage should scroll smoothly.


Additional info:
- checked on a Firefox fresh profile
- checked on Windows XP normal mode
- checked on Windows XP safe mode

Scrolling the webpage on:
- Firefox 44.02 + Windows XP SP3 / Firefox 44 + Xubuntu 14.04 is terrible and janky
- the latest Nightly (multi-process enabled) + Windows XP SP3 is much better, but still a little laggy 
- Opera 35 + Windows XP SP3 / Safari 5.1.7 + Windows XP SP3 is all right

Also tried disabling hardware acceleraton in Firefox but that did not help.

My PC is Intel Celeron G550 2x2.6 GHz, 4 GB RAM, Windows XP SP3 / Xubuntu 14.04

Does the issue is a real bug or is related to the general Firefox slowness (has to be solved by e10s general speed improvements) ? If the issue is e10s related, then it seems that scrolling on the latest Nightly is greatly improved over Firefox 44.02. Keep up good work with e10s and fix scrolling on the webpage and make it as smooth as in Opera or Safari.
Also:
- checked on Xubuntu 14.04
Could you test the latest Nightly with e10s disabled. I  can reproduce the bad scrolling with FF44/45 but not with 46/47.

Did it use to work better with previous versions of Firefox?
Flags: needinfo?(marcino245)
Hello,
very interesting...I also can not reproduce on the latest Nightly 47 with multi-process disabled. 

I did not suppose that it will make a difference between Firefox 44.02 and Nightly with multi-process disabled as I thought it will be the same...

As for the previous versions, I don't know , as I have not go on this page before.

It seems that the bug should be e10s-tracking tagged (from my perspective).
Flags: needinfo?(marcino245)
e10s is still a beta feature so you need to disable it to compare perf between Release and Nightly.
 Tested on Windows XP Professional SP3 Intel Core i5 3.20 GHz 3.40 GB RAM with Firefox Nightly 48(2016-03-09). 
I can confirm what Marcino said. When e10s is enabled the scrolling is moving slower comparing with e10s disabled. 
I think this issue is e10s related.
tracking-e10s: --- → ?
Component: Untriaged → Panning and Zooming
Product: Firefox → Core
Version: 44 Branch → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
somethign we need to worry about?
Flags: needinfo?(bugmail.mozilla)
Priority: -- → P3
(In reply to marcino245 from comment #0)
> 
> Actual results:
> 
> The wepage is not scrolling smoothly

Can you describe in a bit more detail what you are doing - are you scrolling with a mousewheel? Keyboard? Something else? Does the same problem happen with all kinds of scrolling methods?

Also, is it just that the scrolling is "slower" (i.e. it takes longer to get to the bottom of the page) or that it is not "smooth (i.e. it jumps as you're scrolling)? Or both?

On my windows machine this page scrolls smoothly in all the configurations that I tested so I'm not sure offhand what the problem might be. To help narrow it down please also try going to about:config, setting the layers.async-pan-zoom.enabled pref to false, restarting the browser, and seeing if the issue still occurs. (On Nightly please).

Thanks!
Flags: needinfo?(bugmail.mozilla) → needinfo?(marcino245)
As I switched to new PC, can no longer do any tests on the: 
Intel Celeron G550 2x2.6 GHz, 4 GB RAM, HDD 160GB Seagate Barracuda, Windows XP SP3 / Xubuntu 14.04

So I have reproduced and tested the bug on 2 other PCs:
1) Intel Core 2 Duo T7500 2 x 2.2 GHz, 4 GB RAM, HDD 500GB Seagate Barracuda, Windows XP SP3 Pro
2) Intel Core i3-2100 2 x 3.1 Ghz 2c/4t, 4 GB RAM, SSD Samsung 850 EVO 120GB, Windows 7 Ultimate SP1 64bit (my new PC I have switched to)

(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #7)

> Can you describe in a bit more detail what you are doing - are you scrolling
> with a mousewheel? Keyboard? Something else? Does the same problem happen
> with all kinds of scrolling methods?

The bug happens while:
- scrolling with a mouse by clicking, then holding and then dragging scrollbar up/down

On Firefox 45, the bug happen, when scrolling slow or fast
On Nightly 48, the bug happen, when scrolling fast only

The bug NOT happen while:
- scrolling with a keyboard
- scrolling with a mouse by clicking and holding scrollarrows 

Not sure if the bug happens while:
- scrolling with a mousewheel, 
- autoscrolling
as the webpage is long and a mousewheel or autoscrolling take almost no effect on scrolling and scroll very slowly, too slowly to reproduce at 100%. Maybe if I would incerase scrolling strength of a mousewhell or an autoscroll, I would be able to reproduce. At the moment, I didn't mess with strength of wheelscrolling nor autoscrolling.

> Also, is it just that the scrolling is "slower" (i.e. it takes longer to get
> to the bottom of the page) or that it is not "smooth (i.e. it jumps as
> you're scrolling)? Or both?

The second: "it is not "smooth (i.e. it jumps as you're scrolling)"
I attached the movies:
1) https://youtu.be/G8Z_InbU1oA
2) https://youtu.be/oDW84ocg3XE
3) https://youtu.be/S0DonAto2ro
4) https://youtu.be/wl5mnA-1SBo

> On my windows machine this page scrolls smoothly in all the configurations
> that I tested so I'm not sure offhand what the problem might be. To help
> narrow it down please also try going to about:config, setting the
> layers.async-pan-zoom.enabled pref to false, restarting the browser, and
> seeing if the issue still occurs. (On Nightly please).
> 
> Thanks!

Disabling layers.async-pan-zoom.enabled fix the bug on Nightly 48, but it doesn't fix on Firefox 45.
So it seems that not only e10s, but also Firefox is affected too.
Flags: needinfo?(marcino245)
All the tests were done in:

- Firefox's / Nightly's safe mode 
- except the tests with "layers.async-pan-zoom.enabled" disabled, which were done on fresh profiles (as the safe-mode disable also custom settings) + browser restart
- both antivirus + spyware (visible on the movies) were disabled
- no processes were eating CPU nor disks doing anything in background

The bug is purely Firefox's issue.
Thanks for the details! Based on the videos it appears to be caused by main-thread painting slowly.

On Nightly/48 (and Aurora/47) this is likely caused by APZ, because turning off APZ fixes the issue. On previous versions (44/45) there might have been a different root cause, which is now fixed. At least that's my interpretation of what people have said.

So basically, this is now an APZ bug - likely caused by the large displayport and/or event regions. I'll mark it as blocking APZ until we have a change to investigate in more detail.
With e10s disabled, it's really smooth for me, similar to the old versions like it was in the past.
I tried to bisect a fix range and I found it has been fixed by bug 1232577 in 46+:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=26a22167872690258c715c2e45a15bfbd7898e0f&tochange=cf9a5f6f14db0c2e914285a3ef36de9b8dd3cc6a

With e10 enabled, scrolling is less smooth, especially when dragging the scrollbar with the left click.

Then I tried with layers.async-pan-zoom.enabled=false: scrolling is smooth with e10s enabled, like in normal mode.
Depends on: 1232577
CC'ing Brian who might be interested in the results of his patches.
We should be able to fix this by doing displayport suppression during main-thread scrollbar dragging. I can write up a patch for that tomorrow or Friday if BenWa doesn't beat me to it.
Also this is technically a regression from APZ.
Keywords: regression
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #13)
> We should be able to fix this by doing displayport suppression during
> main-thread scrollbar dragging. I can write up a patch for that tomorrow or
> Friday if BenWa doesn't beat me to it.

Tracking that fix under bug 1257369. Feel free to take it over tomorrow if you want.
Depends on: 1257369
This is much better in Nightly now with bug 1257369. I'm going to close it as a duplicate, but please reopen if you feel there are still issues.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1257369
You need to log in before you can comment on or make changes to this bug.