Font Too Small in Form Input Fields

VERIFIED FIXED

Status

()

VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: mrmazda, Assigned: rods)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
2002021216

See bug 124164. Font used when that bug was filed was a user specified font big
enough to read. Current font is the same size used for chrome, which is
marginally useful for chrome and unacceptably small for normal page text.
Compare to the font size used for Netscape 4, which uses a user specified font
size for forms input.
Ok this is definitely the same as 53617

I changed forms.css myself for 0.9.8 which is why it worked when you opened the 
other bug.

Nightlies do not have this change.

You can manually edit forms.css as is mentioned on Steve Wendt's page:

http://www.os2bbs.com/os2news/Warpzilla.html

*** This bug has been marked as a duplicate of 53617 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
I read bug 53617, and it doesn't look like it is necessarily a functional
equivalent of this. This is not a serif vs. sans-serif issue.

Manual edit of forms.css is not a practical fix. I download a nightly virtually
every day, and would have to make this manual change each time, since I have no
way to know I would not blow away other fixes by copying over a previously
edited version each time.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Created attachment 73555 [details] [diff] [review]
Fix for problem

There was already some platform specific code in nsRuleNode.cpp to handle font
stuff, and I decided to add OS/2 to the mix.

On OS/2, for entryfields, lists, and buttons, we will use the same font as the
webpage content unless we are in 4.x quirks mode where we will use monospaced
for entryfields.

This means that you will never get a pretty WarpSans font for controls on Web
Pages on OS/2, but this is necessary on OS/2 because WarpSans is a bitmap font
and does not scale. It should not be used for web content.

Looking for review
*** Bug 116629 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

17 years ago
Comment on attachment 73555 [details] [diff] [review]
Fix for problem

r=rods
Comment on attachment 73555 [details] [diff] [review]
Fix for problem

sr=jst
Attachment #73555 - Flags: superreview+
Fix checked in.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

17 years ago
Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.