Mozilla does not find /usr/lib/mozilla/components/libtimer_gtk.so

RESOLVED INVALID

Status

SeaMonkey
General
--
critical
RESOLVED INVALID
16 years ago
13 years ago

People

(Reporter: Amit K, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226
BuildID:    2002020207

Hi,

I downloaded the 0.9.8 build and also the latest nightly build indicated above.
I downloaded the redhat 7x rpms. Mozilla doesnot start.

I ran it with strace to show what exactly was happening:

--------------------------------------------
open("/usr/lib/mozilla/components/libtimer_gtk.so", O_RDONLY) = -1 ENOENT (No
such file or directory)
write(1, "********************************"..., 310) = 310
write(6, "\22\0\16\0,\0@\0021\1\0\0e\1\0\0\10\0\0\0\36\0\0\0Mozi"..., 644) = 644
gettimeofday({1013668843, 936710}, NULL) = 0
write(5, "\372", 1)                     = 1
gettimeofday({1013668843, 936936}, NULL) = 0
poll([{fd=6, events=POLLIN, revents=POLLIN}, {fd=11, events=POLLIN}], 2, 0) = 1
gettimeofday({1013668843, 937164}, NULL) = 0
poll([{fd=6, events=POLLIN, revents=POLLIN}, {fd=11, events=POLLIN}], 2, 0) = 1
gettimeofday({1013668843, 937330}, NULL) = 0
poll([{fd=6, events=POLLIN, revents=POLLIN}, {fd=11, events=POLLIN}], 2, 0) = 1
gettimeofday({1013668843, 937491}, NULL) = 0
poll([{fd=6, events=POLLIN, revents=POLLIN}, {fd=11, events=POLLIN}], 2, 0) = 1
ioctl(6, FIONREAD, [160])               = 0
read(6, "\26\0\31\3u\0@\2u\0@\2\0\0\0\0\5\0\1\0\1\0\1\0\0\0\0\0"..., 160) = 160
gettimeofday({1013668843, 937883}, NULL) = 0
poll([{fd=6, events=POLLIN}, {fd=11, events=POLLIN}], 2, 0) = 0
gettimeofday({1013668843, 938045}, NULL) = 0
poll([{fd=6, events=POLLIN}, {fd=11, events=POLLIN}], 2, 0) = 0
ioctl(6, FIONREAD, [0])                 = 0
gettimeofday({1013668843, 938249}, NULL) = 0
ioctl(6, FIONREAD, [0])                 = 0
poll([{fd=6, events=POLLIN}, {fd=11, events=POLLIN}, {fd=4, events=POLLIN,
revents=POLLIN}], 3, 0) = 1gettimeofday({1013668843, 938679}, NULL) = 0
gettimeofday({1013668843, 938930}, NULL) = 0
gettimeofday({1013668843, 939351}, NULL) = 0
gettimeofday({1013668843, 939663}, NULL) = 0
open("/usr/lib/mozilla/components/libtimer_gtk.so", O_RDONLY) = -1 ENOENT (No
such file or directory)
write(1, "********************************"..., 310) = 310
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++
--------------------------------------------

Reproducible: Always
Steps to Reproduce:
1. Just starting it will do it
2.
3.

Comment 1

16 years ago
Where exactly did you download these builds from? Was the error the same in all
builds?
Could you try removing the component.reg file in your Mozilla directory and
running it again?

Comment 3

16 years ago
It seems this is the Ximian problem with their 0.9.8.
Resolving as dup of bug 125325 since reporter hasn't replied.

Reporter: In the comment found in
http://bugzilla.mozilla.org/show_bug.cgi?id=125325#c4
you will find a way to cure this situation.

*** This bug has been marked as a duplicate of 125325 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
Got mail from reporter, which I'm not sure how to interpret.
Reopening for confirmation.

Reporter wrote:
"Downloaded from Mozilla.org...no !! its not in the ximian builds ! "


Reporter: This bug is indeed in the Ximian builds.
Rassigning to blizzard to see if it is also an issue in rpms on ftp.mozilla.org

Status: RESOLVED → VERIFIED

Comment 5

16 years ago
umm
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

16 years ago
reassigning.

Comment 7

16 years ago
trying again
Assignee: asa → blizzard

Comment 8

16 years ago
delete your component.reg file and make sure none of your old mozilla's are in 
your path.  The functionality from libtimer_gtk is now handled by a different 
library so we no longer ship with that file.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

16 years ago
Well...after a lot of different combinations, i got the 0.9.8 working.

The funny thing was that from the beginning it was working with the 'installer'
tarballs, but didnot work with the RH 7.1 RPM downloaded from mozilla.org.
Besides this i was having problems with the plugins working under 0.9.8 which i
was told was due to a 'plugger' bug.

So that was resolved. Let me know if u need me to run any specific steps. It
would be great if u told me the exact steps.

Regards,
Amit
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.