Closed Bug 1254358 Opened 6 years ago Closed 6 years ago

Latest Nightly Mac build are "damaged" and can't be opened

Categories

(Instantbird :: Other, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: algritz, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.116 Safari/537.36

Steps to reproduce:

Downloaded the DMG file, mounted it. Copied the executable to the /Applications folder. Tried to start the application.


I am running Mac os X 10.11.3 (OS X El Capitan)


Actual results:

Got an error message saying that the application was "Damaged", only option was to move it to trash.


Expected results:

Application should have started just fine.
Severity: normal → blocker
Priority: -- → P1
I just followed your steps to reproduce and everything works fine. I too am running 10.11.3. Please double check the integrity of the DMG file you downloaded. The md5 should be 0270db52c0e8cef72640df95af1cfa37.
Severity: blocker → normal
Priority: P1 → --
shasum instantbird-1.6a1pre.en-US.mac.dmg 
2e38b21549bcec4372dc85cc63ccb41d3f63ae4e  instantbird-1.6a1pre.en-US.mac.dmg

Tried to download using Firefox and Chrome as well as a wget from terminal, they all yield this checksum.

My HD is encrypted (McAffee Endpoint encryption), could it mess with the DMG ?
The shasum is the same for me. I don't believe encryption has anything to do with it. From a quick Google search, it seems that if you delete and reinstall (or update) an app that is not from the App Store or an "Identified Devleoper" that you previously allowed to run anyway, you might run into this "damaged" dialog due to an OS X bug [1]. Please try allowing apps downloaded from "Anywhere" in System Preferences -> Security & Privacy -> General, and then reopen Instantbird. Once done, you should be able to reset the preference and keep using Instantbird with no problems.

[1] http://www.mackungfu.org/dealing-with-damaged-and-can-t-be-opened-error-messages
That fixed it, thanks a lot!
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.