libpng warnings about iCCP chunk

VERIFIED FIXED in mozilla1.2alpha

Status

()

Core
ImageLib
P4
minor
VERIFIED FIXED
16 years ago
12 years ago

People

(Reporter: Jeremy M. Dolan, Assigned: Stuart Parmenter)

Tracking

Trunk
mozilla1.2alpha
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I've been getting lots of these lately...never notice what site exactly triggers
it. Didn't see an open bug on it.

libpng warning: Incomplete compressed datastream in iCCP chunk
libpng warning: Profile length missing in iCCP chunk

Been happening for a few weeks at least.

Comment 1

16 years ago
My Mozilla nightly is a few weeks old but I get the same error and I get it on
for example:

http://www.debianplanet.org

so there you have a site to test it on.

   /Samuel
(Reporter)

Comment 2

16 years ago
Yep, reproducable with 1.0 branch on that site. Adding URL. Thanks.

Maybe we want to comment out these warnings for release?
(Assignee)

Updated

16 years ago
Priority: -- → P4
Target Milestone: --- → mozilla1.2alpha

Updated

16 years ago
Depends on: 128502

Updated

16 years ago
No longer depends on: 128502

Comment 3

16 years ago
Commenting out the png_warning() wouldn't be the best solution because that
wouldn't affect installations that use the system libpng instead of Mozilla's
built-in libpng.

Glenn

Comment 4

16 years ago
Created attachment 91222 [details] [diff] [review]
register quiet warning and error callbacks for libpng

Comment 5

16 years ago
Tor's patch looks OK to me.

Glenn
Comment on attachment 91222 [details] [diff] [review]
register quiet warning and error callbacks for libpng

r=biesi
Attachment #91222 - Flags: review+
Comment on attachment 91222 [details] [diff] [review]
register quiet warning and error callbacks for libpng

sr=blizzard
Attachment #91222 - Flags: superreview+

Comment 8

15 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.