error C2220 in gfx/vr/ovr_capi_dynamic.h when compiling Unified_cpp_gfx_vr0.cpp on Visual Studio 2015

RESOLVED DUPLICATE of bug 1242005

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1242005
2 years ago
2 years ago

People

(Reporter: gps, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
From at least the 32-bit builds at https://treeherder.mozilla.org/#/jobs?repo=try&revision=343a8e570f7a using Visual Studio 2015, we get the following compiler warning turned into an error:

22:40:14     INFO -  python2.7 c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/sccache/sccache.py cl -FoUnified_cpp_gfx_vr0.obj -c -Ic:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/obj-firefox/dist/stl_wrappers  -DDEBUG=1 -DTRACING=1 -DWIN32_LEAN_AND_MEAN -D_WIN32 -DWIN32 -D_CRT_RAND_S -DCERT_CHAIN_PARA_HAS_EXTRA_FIELDS -DOS_WIN=1 -D_UNICODE -DCHROMIUM_BUILD -DU_STATIC_IMPLEMENTATION -DUNICODE -D_WINDOWS -D_SECURE_ATL -DCOMPILER_MSVC -DSTATIC_EXPORTABLE_JS_API -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -Ic:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/gfx/vr -Ic:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/obj-firefox/gfx/vr -Ic:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/gfx/thebes -Ic:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/obj-firefox/ipc/ipdl/_ipdlheaders -Ic:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/ipc/chromium/src -Ic:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/ipc/glue -Ic:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/obj-firefox/dist/include  -Ic:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/obj-firefox/dist/include/nspr -Ic:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/obj-firefox/dist/include/nss        -MD -FI c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/obj-firefox/mozilla-config.h -DMOZILLA_CLIENT -deps.deps/Unified_cpp_gfx_vr0.obj.pp  -TP -nologo -Wv:18 -Zc:sizedDealloc- -Zc:threadSafeInit- -wd4091 -D_HAS_EXCEPTIONS=0 -W3 -Gy -arch:IA32 -FS -wd4251 -wd4244 -wd4267 -wd4345 -wd4351 -wd4800 -wd4819 -we4553 -GR-  -Z7 -O1 -Oi -Oy- -WX -Ic:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/obj-firefox/dist/include/cairo    c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/obj-firefox/gfx/vr/Unified_cpp_gfx_vr0.cpp
22:40:26     INFO -  Unified_cpp_gfx_vr0.cpp
22:40:26     INFO -  c:\builds\moz2_slave\try-w32-d-00000000000000000000\build\src\gfx\vr\ovr_capi_dynamic.h(392): error C2220: warning treated as error - no 'object' file generated
22:40:26     INFO -  c:\builds\moz2_slave\try-w32-d-00000000000000000000\build\src\gfx\vr\ovr_capi_dynamic.h(392): warning C4359: '<unnamed-tag>': Alignment specifier is less than actual alignment (8), and will be ignored.
22:40:26     INFO -  c:\builds\moz2_slave\try-w32-d-00000000000000000000\build\src\gfx\vr\ovr_capi_dynamic.h(401): warning C4359: '<unnamed-tag>': Alignment specifier is less than actual alignment (8), and will be ignored.
22:40:26     INFO -  c:\builds\moz2_slave\try-w32-d-00000000000000000000\build\src\gfx\vr\ovr_capi_dynamic.h(412): warning C4359: '<unnamed-tag>': Alignment specifier is less than actual alignment (8), and will be ignored.
22:40:26     INFO -  c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/config/rules.mk:964: recipe for target 'Unified_cpp_gfx_vr0.obj' failed
22:40:26     INFO -  mozmake.EXE[5]: *** [Unified_cpp_gfx_vr0.obj] Error 2
22:40:26     INFO -  mozmake.EXE[5]: Leaving directory 'c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/obj-firefox/gfx/vr'
22:40:26     INFO -  c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/config/recurse.mk:71: recipe for target 'gfx/vr/target' failed
22:40:26     INFO -  mozmake.EXE[4]: *** [gfx/vr/target] Error 2

No clue what the problem is - I strangely don't see any more context in the build log.
(Reporter)

Comment 1

2 years ago
So, there are the C4359 warnings following the C2220 warning. Does Visual Studio emit the C2200 before the warnings that triggered it?
(Reporter)

Comment 2

2 years ago
Looks like a dupe of 1242005. I should learn how to read build system output :)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1242005
You need to log in before you can comment on or make changes to this bug.